0

I've searched and noticed other people having the same issue but no fixes.

Recently my trackpad stopped working which resulted in me changing it.

Worked fine for months. All of a sudden my trackpad left-click stops working and even if I plug in a mouse, it doesn't work, but the right click on the plug-in mouse works fine.

The left click works fine in Diagnostics mode, works every time. But works nowhere else.

I thought I would reinstall the OS to see if that would fix it.... but now I cannot install the OS as I get stuck on the page where you have to click the Hard drive and press next, can't seem to do that with the keyboard only.

Any suggestions? Need to work from home and can't get it working. Model A1502 Macbook pro Thank you.

  • The most likely cause of this is that your trackpad is stuck in the left click down. If you can, remove the back cover and disconnect the keyboard/trackpad. You'll need an external keyboard/mouse to continue. If this solves your issue, unfortunately, it's the trackpad again. – Allan May 5 at 1:00
  • Also, what specific MacBook Pro do you have? A1502 covers models from 2013 through 2015. And..what version of macOS were you using? – Allan May 5 at 1:05
  • That still doesn't explain why it works every time in diagnostics mode and also why a plug in mouse isn't working? – Liam J May 5 at 10:06
  • @Allan pretty sure it's 2015 (sorry can't remember and cannot access it to see it) – Liam J May 5 at 23:34
  • There are some instructions on how to remove the trackpad but in your case, you just want to disconnect it. This way, you isolate it from the system. It will do two things, confirm the issue and get you up and running. – Allan May 5 at 23:39
1

I would recommend splitting this question in 2 since you had 2 different issues even though they are affecting each other.

  1. First one (this post) would be to only figure out how to reinstall OS with just keyboard. Take some pictures with your phone and post them along with your question so we can help you better.
  2. If your input hardware doesn't work even after the OS re-install, post your second question with the new post-OS-install details.

As for your hardware, have you tried using tab and shift + tab to change focus (indicated with a blue boundary) and use spacebar to select that button, while enter only works for the button filled entirely with blue colour.

| improve this answer | |
  • Okay, thank you. Tried that, no luck. This is the screen I get stuck on. I can somewhat hover over the hard drive, as you can see from the border around the hard drive but nothing else. link – Liam J May 4 at 23:49
  • Hang on a moment here...before going through an OS reinstall, let's get the hardware issue sorted first. If the OP is getting stuck in macOS Installation, then a reinstall won't work as the Installation is, in and of itself, a clean version of macOS. – Allan May 5 at 1:02
  • ^point. Have you tried running the MacBook in safe mode? do you see the same issues there as well? Also, instead of links you should add the images inside the comments/posts itself. – fidgetyphi May 5 at 2:57
  • Already wiped the harddrive clean, no back up also. Didn't think I'd have a problem since I've been able to navigate every other menu. – Liam J May 5 at 9:00
  • I have some video examples just can’t upload them – Liam J May 5 at 18:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .