1

I'm having a horribly frustrating issue that I can't seem to work out. Here are the steps to reproduce the problem, which happens with both an external Logitec VX mouse, the internal MacBook Pro Trackpad and the Magic Trackpad.

  1. I move the pointer to a click location, and tap the trackpad. No click is registered.

  2. I tap the trackpad again, and a click is registered.

  3. I move the pointer to a new location, and tap the trackpad. The click is registered.

  4. I let the pointer hold in a single location for some (as yet undetermined amount of time).

  5. I move the pointer to a click location, and tap the trackpad. No click is registered. It again takes two clicks to "unstick" the click.

This happens all the time when I'm coding, and I'll click and drag something, go to my keyboard, and then go back to the mouse, and I'll have to double click to get a single click to register. If I let the mouse stand idle, I'll have the same issue.

I haven't been able to dig out why this happens. I have, on occasion, been able to restart my MacBook Pro and it would magically start working again, but then at some point it starts to once again misbehave.

Machine Specifications:

  • MacBook Pro 17-inc, Mid 2010
  • 8GB RAM
  • OS X Lion 10.7.2
0

The issue was with jiTouch. Once I uninstalled jiTouch and restarted my computer, everything went back to normal. I'm now using BetterTouchTool, and it seems to be working perfectly.

0

This has also been an aggravation for me on my MacBook Pro 17-inch for several years. I am normally averse to installing addons, but I got so frustrated I tried MagicPrefs a few days ago, and it seems to have solved the problem.

-1

Had the same issue with my MacBook Pro. Didn't have JiTouch installed.

What seems to have resolved it for me was to adjust my Accessbility settings:

System Preferences -> Accessibility -> Mouse & Trackpad

There is an option, which was unchecked, "Spring-loading delay:"

I moved the slider all the way left to "short".

This seems to have fixed it for me.

I suspect that when I upgraded OS X to El Capitan, the setting took effect, even though it wasn't selected. Selecting it and reducing it to the minimum got rid of this. I suspect this is a kind of "debounce" against accidental clicking of the trackpad.

  • spring loading has to do with "how long an item has to be over a folder before the folder opens." – Robert S Ciaccio Sep 16 '16 at 5:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .