9

I've got a frustrating problem that seems to have cropped up within the last two months or so.

Infrequently, the left (primary) click stops registering with the OS, so I can't really click on anything. My mouse moves around the screen, I can right (secondary) click, but I just can't perform a primary click.

I'm running 10.6.8 on an Early 2011 MacBook Pro (http://support.apple.com/kb/SP619). The click stops registering both on the trackpad and my Magic Mouse.

A restart solves the problem.

Any ideas?

  • What happens if you remove secondary click from the magic mouse configuration so it becomes a single button mouse with both sides giving primary click? Does it still lose the the primary click? – Stu Wilson Jan 13 '12 at 23:22
  • Haven't tried that. It happens infrequently, so I'd hate to give up my right click, but perhaps I can give it a shot for a day or so to see what happens. What's your reasoning for trying this? – djibouti33 Jan 13 '12 at 23:26
  • Purely to confirm as a software issue. If the right hand side exhibits the same issue as the left then it's software (which given you have a similar issue with the trackpad is almost a given). If RHS does not exhibit the same issue, then software is less likely but makes your trackpad issue an oddity. I'm betting the issues will continue but can't for any good reason think of a reason why unless there's a memory leak in the driver – Stu Wilson Jan 13 '12 at 23:38
  • I stated having the same problem with an older macbook pro (2008) without a separate trackpad or mouse. Added a track pad, think the built in one had died. No luck. add a logitech usb mouse. Works for a while (and so does the trackpad). then dies. Only the primary click goes away. It act to me like some sort of memory leak that overwrites the control of the primary mouse click. – user17214 Jan 16 '12 at 16:51
  • You running anything that might be interfering with clicks, like a third party driver? – Steven Fisher Apr 26 '12 at 2:57
3
  • Double check that you don't have any stuck keys on your keyboard by testing all the keys, particularly the modifiers (shift, option, etc).
  • Make sure there aren't any wizards, alerts, or dialogs hidden behind existing windows or in other spaces (this one gets me often, especially running the odd mix of programs I use daily).
2

Check that your external trackpad that you now rarely use does not have a book on it! That’s what confused me for at least 10minutes

1

I posted this in another thread, It fixed the single click issue for me.

https://apple.stackexchange.com/a/130552/78030

1

I had this same problem: no mouse devices registered a left click (internal trackpad, external trackpad, USB mouse). Right click, oddly, worked.

It turned out I had a Magic Mouse I had left in a bag that was turned on. It was compressed which registered as a button press, so no other mice/trackpads could register a left click. Taking it out and turning it off solved the issue.

I guess OS X doesn't differentiate between input devices.

0

So I had the same problem on my 2006 macbook, also running 10.6.8. I was convinced it was a software problem until I read a post somewhere that said it could be an old battery that has expanded and is putting pressure on the trackpad. So I took out the battery,made sure the power supply was plugged in an booted up...bingo, problem solved. I then left my battery in a freezer for a while to make any swelling go down and when I put it back, all working fine for now. So I might have to keep doing this if the problem comes back again :)

0

Macbook Pro with Apple Mouse and battery was at 82%. The mouse would move but neither the left or right buttons worked. It turned out to be simply a dirty connection on one of the batteries. Removed the batteries, scraped the connection on the mouse, re-inserted the batteries and success!

-1

restart the bluetooth works for me

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .