6

I have U.S. and Japanese (Hiragana) input on the keyboard. There's a feature in macOS "Use the Caps Lock key to switch to and from U.S.". So, pressing Capslock switches between U.S. and Japanese fine for the most part, but the problem is that if I press Capslock immediately after typing a U.S. character, it does nothing. I have to wait a few moments before I can press Capslock to switch to Hiragana. Likewise, if I'm in Hiragana and I press Capslock immediately after finishing typing Hiragana, it does nothing. I have to wait a moment before pressing Capslock to change back to U.S.

Anyone know how to remove this delay? It's frustrating.

3

3 Answers 3

1

You might try adding Romaji to your Japanese input choices and playing with the preferences for Caps Lock and Shift Key action to see if you get the performance you want.

enter image description here

0

I also face the same problem and it's really annoying. Tried every solutions out there but not working. So I end up changing the key to ⌘ CommandSpace.

3
  • Welcome to Ask Different! We're trying to find the best answers and those answers will be more than just 1-2 lines. Providing supporting info and links can also help the OP, and others, find additional info for themselves. See How to Answer on how to provide a quality answer. - From Review
    – fsb
    Apr 19, 2020 at 12:35
  • While this does answer the question, I would advise against this. Cmd-Space pulls up spotlight search which is a super powerful too. Try this instead: apple.stackexchange.com/a/382750/119271
    – Allan
    Apr 19, 2020 at 18:29
  • Kawa doesn't help. I change spotlight shortcut to option+space before changing capslock to cmd+space so there's no problem with spotlight
    – Bank
    Apr 20, 2020 at 13:59
0

The only reliable way to get rid of the delay, in my experience, is to use karabiner-elements.

  1. Install karabiner-elements.
  2. Remap the Caps-Lock key to a function key, e.g. F17, by adding the mapping in the "Simple Modifications" tab.
  3. Then open System Preferences -> Keyboard -> Keyboard Shortcuts -> Input Sources. And set F17 as the key for selecting the next input source.

When it's done this way, the delay disappears.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .