1

I have resized my main drive from 250gb to 200gb so I could have 50gb for Windows 10. Installation via boot camp failed and I was left with two partitions. Somehow I deleted the smaller one (for Windows) and now I can not reclaim that space and resize my main partition to its original size of 250gb.

➜ diskutil list
/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *251.0 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                 Apple_APFS Container disk1         192.0 GB   disk0s2
   3:       Microsoft Basic Data OSXRESERVED             8.0 GB     disk0s3

/dev/disk1 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +192.0 GB   disk1
                                 Physical Store disk0s2
   1:                APFS Volume Macintosh HD            140.0 GB   disk1s1
   2:                APFS Volume Preboot                 45.8 MB    disk1s2
   3:                APFS Volume Recovery                1.0 GB     disk1s3
   4:                APFS Volume VM                      1.1 GB     disk1s4

DiskUtility:

DiskUtility not showing entire free space

I have tried resizing apfs container:

➜ diskutil apfs resizeContainer /dev/disk0s2 240g
Started APFS operation
Aligning grow delta to 48,000,000,000 bytes and targeting a new physical store size of 240,000,000,000 bytes
Determined the maximum size for the targeted physical store of this APFS Container to be 192,000,536,576 bytes
Error: -69771: The target disk is too small for this operation

Does anybody know how to reclaim that "invisible" free space and how to expand my main partition?

Any help is much appreciated.

1

Open a Terminal application window and enter the following commands.

sudo diskutil erasevolume free none disk0s3
sudo diskutil apfs resizecontainer disk0s2 0
| improve this answer | |
  • I tried doing that and after second command I get: The volume /dev/disk0s2 appears to be OK Storage system check exit code is 0 Growing APFS Physical Store disk0s2 from 192,000,000,000 to 250,790,436,864 bytes Modifying partition map Growing APFS data structures APFS Container Resize error code is 49168 A problem occurred; undoing all changes Modifying partition map Error: -69606: A problem occurred while resizing APFS Container structures Do you have an idea what could be the problem? – 4evertoblerone Mar 24 at 20:54
  • I also tried turning off time machine and deleting any snapshots that may have existed but resizing still ends with the same error. – 4evertoblerone Mar 24 at 21:38
  • The message indicates there must be something wrong with the APFS container. You now have discovered a problem which is beyond your original question. You could try using the Disk Utility to run first aid. I would recommend backing up any important data before proceeding. You could ask a new question or modify your exist question. I do not have an answer that can fix this new problem. – David Anderson Mar 25 at 6:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .