I'm using macOS Catalina and I want to use screen sharing in Slack. But when the permission prompt came up I accidentally clicked Deny because it was the default option.

Now I can't get the prompt to come up again. How can I reset permissions so that the prompt comes up again?

  • Doesn’t slack show in the system preferences without a check mark in this case? All my tests show this working, but perhaps there’s some difference I’m missing.
    – bmike
    Commented Apr 6, 2020 at 19:42
  • 1
    @bmike it's supposed to, yeah. But I've seen oddities.
    – Nic
    Commented Apr 6, 2020 at 22:10

2 Answers 2


You need to use tccutil to manage the privacy database -- this involves opening the Terminal and using the command line! If you know the bundle ID of the app you're trying to use, you can use this command:

tccutil reset ScreenCapture [com.WHATEVERBUNDLE.YOURAPPID]

Here are some examples for common applications:

  • tccutil reset ScreenCapture com.apple.Safari Safari
  • tccutil reset ScreenCapture org.mozilla.firefox Mozilla Firefox
  • tccutil reset ScreenCapture com.google.Chrome Google Chrome
  • tccutil reset ScreenCapture com.apple.QuickTimePlayerX QuickTime Player

If you're trying to use screencapture on the command line, your terminal application needs to be granted permission.

  • tccutil reset ScreenCapture com.apple.Terminal Terminal
  • tccutil reset ScreenCapture com.googlecode.iterm2 iTerm 2

If you don't know the app bundle ID, then you can just clear and reset the privacy settings for ScreenCapture for all applications. Note that this will remove all entries from the list of apps allowed to do Screen Recording, and you'll have to re-add them individually.

tccutil reset ScreenCapture

Once you've reset the privacy permissions, you must quit your application before the change will take effect. Then you can restart your app and try screen recording again, and the prompt should reappear.

Help, it's still not working!

Make sure that System Integrity Protection is enabled, otherwise these commands won't work correctly. To check, you can run csrutil status and it should say System Integrity Protection status: enabled.

You can also try creating a new user account with admin privileges and setting up the Screen Recording permissions in that account. That sometimes helps to put the TCC database back in a good state. This seems to be useful in some cases where the prompt window just isn't shown at all.

  • Good call out on SIP. I don’t often run like that or test like that.
    – bmike
    Commented Apr 6, 2020 at 19:42
  • A good start, but once you reset something, it wipes out everything out from the registry, even apps that were used to be in the list. The results is still the same, you can add the app in again. Any hint? Commented May 7, 2020 at 6:40
  • Switching to a non-admin account and setting up Screen Recording there (for Quicktime) brought the permissions back for my primary (admin) account. Thanks! Commented May 9, 2020 at 21:51
  • 1
    Update 2: I have to switch to my other account to grant permissions to all new apps too (e.g., Camtasia). It's slightly annoying, but it works! Commented May 9, 2020 at 23:42
  • @DanRosenstark same for me. I'm still looking for what it is in the user profile that prevents an app from registering itself in that list of apps. Commented Sep 1, 2020 at 12:59

I think I've had the same problem with Zoom. The way it worked for me was

  1. uninstall the app (ex. Zoom or Skype)
  2. reboot the computer (very important, uninstall is not enough)
  3. Reinstall the app and the permission dialog comes up. Note that you'll get both OS's permission dialog and the one from the App. Go straight to OS.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .