10

Please note: this question is very similar to this one and others, but none of them involve giving Google Chrome access to the Screen Recording permission! The link above is for giving Slack permission, but that is not what I'm trying to do, and as you'll see by my screenshot below, Catalina is behaving especially strange in the case of Chrome. Please do not DV/CV as a dupe!


Mac OS Catalina 10.15.3 here. In Chrome I am joining a Google Meet video conference and cannot present my screen because Chrome doesn't have screen recording permission. The generally accepted solution is to go to System Preferences >> Security >> Privacy and allow Chrome to have Screen Recording permissions as indicated by the following screenshot:

enter image description here

However when I go to System Preferences >> Security >> Privacy, all I see is:

enter image description here

Which indicates only my Slack app has screen recording privileges. I need to add Google Chrome to this list, but I can't figure out how to do that! I do not see where I can search for apps to add to the Screen Recording permissions list. Any ideas?

If I try to present my screen from inside an existing Google Meet meeting, I get a warning that I need to give my camera permission, and I am given a link to go into System Preferences and change permissions. However when I click the link, again, only Slack is available as an option.

3
  • 1
    You have to launch Google Meet, create/join a meeting - anything to get it to try and access your camera, when it asks for permission, say "yes." This permissions interface is a disaster IMO.
    – Allan
    May 21 '20 at 21:17
  • Thanks @Allan (+1) but please re-read my last paragraph above; that's exactly what I did and the last screenshot is what I see when I do that... May 23 '20 at 15:17
  • Did you give google meet permission in the Chrome browser, if you stop it there it never reaches os level so won't make a request to add it there. Also worst case, back up your chrome settings locally or to your google account. Sign out. Uninstall chrome fully i.e. also delete prefs and application support folders install chrome again and try again.
    – user14492
    May 31 '20 at 15:42
8
+50

It looks like as long as an app does not try to capture or record the screen, the app cannot be manually added to the "Screen Recording" list. For other permission types such as Full Disk Access, I have successfully dragged and dropped an application to add to the list.

In that case, you can open Google Chrome, visit this site and click the "Get Started" button. I have tried it on MacOS Catalina 10.15.4 with Google Chrome 83.0.4103.61 (Official Build) (64-bit), and it worked. After pressing the "Get Started" button, Chrome requested permission to record screen, and then afterwards, I could go to settings->Security & Privacy and then grant permission for Screen Recording.

During my test, I already had the Security & Privacy window open, and already clicked the Lock icon to make changes and entered my password.

Afterwards, I have tested with Google meetings and confirmed that I can share my screen. I have also confirmed that when I deselect Chrome from the Screen Recording list, I can't share the screen.

Hope that works for you, too.

2
  • 1
    For me works! But Chrome needs a restart after setting the permission. And then it will stay in the Screen Recording list. When the app is added once, you can just check or uncheck the checkobox and the app will stay in the list. Only the first time there is no "+" or Add button.
    – KargWare
    May 26 '20 at 18:19
  • After an hour of searching found this, Perfect.
    – dev
    Nov 28 '20 at 22:45
0

I was having the same issue and found this thread that recommended opening Google meet in an incognito window. For some reason, the incognito window was successful in requesting the correct permission when a regular window was not 🤷‍♀️

0

I found that when Google Chrome attempted to request the Screen Recording permission, the corresponding system dialog opened in the background, and it was only some time later after closing several windows that I noticed it (I already had system preferences open at the time). After trying to use Screen Recording in Chrome, if you don't see a dialog, try:

Ctrl(^)-click System Preferences > Show all windows

On the dialog, select 'System Preferences' and this should add Google Chrome to the list.

0

It could be that you just need to insert your password by clicking on the lock in the bottom left (click the lock to make changes). This will make Chrome available to be added in the list of allowed apps.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .