2

On macOS Sonoma, screen sharing has a new "High Performance" option. However, whenever I try to turn it on, I just get a black screen. Both the server and the client are running the latest beta (23A5301g) of Sonoma.

  • The same also happens when the server is a VM running under UTM on the client machine, so that network speed is infinite for all practical purposes.
  • The exact same setup works fine when changing the screen sharing type back to "Standard".

I’m not aware of any client or OS settings to adjust, so I'm a bit baffled how I might solve this.

Does anyone have an idea what is needed to make high performance screen sharing on macOS Sonoma work?

In all cases where I've encountered this behaviour, the connection was not "standard": either I was using a VPN or I was connecting to a VM. This appears to be a bug and is still not fixed in the initial release version of macOS Sonoma. I did report it to Apple, but they closed it with "unable to diagnose with current information"...

Sonoma is now out of beta, but this bug hasn't been fixed. It is also present in the current 14.1 beta.

5
  • 1
    Sonoma is still in beta, so make sure to provide feedback to Apple about this. Having said that: Which Mac hardware are you using on the ends of the screen sharing setup?
    – nohillside
    Jul 29, 2023 at 18:25
  • Will do, I was just surprised it doesn't work for me at all... The client is a first-generation M1 Mac mini and the server is an M1 Max Mac Studio.
    – Martin
    Jul 29, 2023 at 19:10
  • 1
    Did you ever sort this out? I'm now having the same problem, though strangely it works for controlling 2 of my 3 computers (remote controlling MacBook Pro M1 Max works, M1 Mac mini works, but controlling M2 ultra studio does not). Aug 16, 2023 at 17:36
  • 1
    @CaeliusAurelianus I'm now in a situation similar to yours. I just got a 15 inch MB Air and controlling the mini from the Air and vice-versa works. However, controlling the studio doesn't. Possibly it has to do with the latter being accessed through a VPN, but that doesn't explain why controlling the VM's doesn't work either... In any case, even when the controlling works, the server switches to a blank screen when it is being controlled; maybe that's intended.
    – Martin
    Aug 16, 2023 at 21:23
  • 1
    @CaeliusAurelianus It definitely seems related to the VPN, at least for me: if I access the studio from the MB Air, but on the same network rather than via VPN, everything works fine. (Except for the thing of the screen of the host turning black.) Are you trying to control your studio via a VPN?
    – Martin
    Aug 17, 2023 at 11:46

2 Answers 2

2

According to docs

Both Mac computers must be able to communicate with each other over UDP ports 5900, 5901, and 5902

It looks like they should be on the same network and router port forwarding would not be sufficient

I use Tailscale and high performance mode works

1
  • 1
    Ah, that must have been it, thanks. Weird though that the screen sharing app doesn't throw an error message with an explanatory note.
    – Martin
    Feb 16 at 20:44
0

Using a Wireguard tunnel directly to the remote machine allows High Performance mode to work for me. It's a super-basic tunnel, no IP forwarding or firewall rules at the remote machine, just using the App Store version of Wireguard at both ends and forwarding the default port on the remote router -- I haven't yet tried a more sophisticated setup. There does not appear to be any lag, at least on my home 1Gbps connection (faster than what the remote machine is on).

Audio only seems to work if sharing a single window at 1:1 resolution -- adding a second window or trying to scale causes loud audio noise, but that appears to be an unrelated bug (see reddit thread). Even without that, audio is only marginally useful if you're trying to do actual audio-related work, as you can't select which sources route to the screen-sharing output -- you get them all.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .