2

Today I've just started getting a warning dialog when I try to run the RSA SecurID app:

This is a Java app I believe. I use it to authenticate when I connect to my company's private network. I've been running Catalina (10.15.3) for some time but this has only just started happening today (after a reboot, FWIW).

Unlike previous Gatekeeper interventions there doesn't seem to be any obvious way to circumvent this warning and run the app, which is problematic as I can't work remotely without it.

UPDATE:

As suggested in the comments below, I downloaded and installed SecurID 4.2.1, and I now get a similar error message:

enter image description here

6
  • 2
    I would uninstall it and try to install it back again with new download from community.rsa.com/docs/DOC-62004. Have you tested in this way?
    – Udhy
    Mar 5 '20 at 12:14
  • 1
    You should also contact your company's IT department about this as well as attempting a reinstall.
    – IconDaemon
    Mar 5 '20 at 12:18
  • @Udhy: thanks - I tried that but now I get a similar warning: "stauto32.framework will damage your computer". I thought it might be something to do with malwarebytes but I uninstalled that and rebooted and the problem persists.
    – Paul R
    Mar 5 '20 at 12:36
  • @IconDaemon: my IT department is about as useful as a chocolate teapot - they refuse to support macOS - only Windows and iOS.
    – Paul R
    Mar 5 '20 at 12:37
  • 1
    Sorry about your IT department. At least you can eat a chocolate teapot. :-)
    – IconDaemon
    Mar 5 '20 at 12:48
4

I had this same issue come up today - there must be some definition added to these scanners that's picking up the SecurID app. On one laptop, I was able to resolve it with just step 2 and 3 below but on another, I had to do the first as well. Since you're getting the stauto32.framework error, you'll probably need both steps like I did.

Step 1 - Delete the existing stauto32.framework folder - found at /Library/Frameworks/stauto32.framework

Step 2 - Download and run the 4.2.1 installer for the software token from RSA to upgrade or ensure the right things are all installed where they should be

Step 3 - open the info panel of the SecurID application in the Applications folder and check the 'Override Malware Protection' box

After that, when you run the app, it will ask for your password to access its various pieces stores in the Keychain and will also request access to a couple disk folders used in importing new tokens.

I hope that works for you as it did in our case!

3
  • Thanks @Mike: can you clarify what you mean in step 3 though - when you say "open the info panel of the SecurID application" do you mean the Finder's "Get Info" dialog ? I don't see any 'Override Malware Protection' checkbox there ?
    – Paul R
    Mar 6 '20 at 9:18
  • Yay success ! I just tried steps 1 and 2 and that seems to have worked ! The lack of an 'Override Malware Protection' checkbox in my Finder Get Info panels is a myatery, but in the end it doesn't look like I needed it. Thanks for your help.
    – Paul R
    Mar 6 '20 at 9:54
  • 1
    @PaulR - Glad it worked out! I'm not sure why the Override Malware Protection wasn't showing on there. To clarify, I did mean the Finder Get Info panel, but maybe that only shows in certain contexts. Anyway, as long as it's running now, that's the goal.
    – Mike
    Mar 7 '20 at 15:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .