9

When trying to run VLC, El Capitan reports this message:

“VLC.app” will damage your computer. You should move it to the Trash.

I tried downloading a fresh copy of VLC, but this didn't fix the issue.

How can I run VLC on El Capitan?

P.s. I tried the "control-open" but unlike Mavericks, that didn't allow the application to start.

  • 1
    It will not damage your computer. The app is damaged. – At0mic Oct 5 '15 at 1:27
  • 2
    @IronCraftMan Can you please support your opinion that "the app is damaged" ? VLC passed verification on both the DMG and the .app several times. Even when re-downloaded. – nslntmnx Oct 5 '15 at 4:02
  • that is what OS X says. Even if it isn't. If there is something changed in the Code signing of the app, it will disappear the message. – At0mic Oct 5 '15 at 13:41
  • 3
    There appears to be a closed ticket for this. Looks like it will be fixed in version 2.2.2. – jakar Nov 10 '15 at 13:34
  • @jakar nice find! – nslntmnx Nov 10 '15 at 21:15
8

I've had the same issue with El Capitan. Strangely, i could open the VLC.app from within the mounted dmg (OS X just said its unsigned) but not after I copied it to /Applications.

So I tried to copy it with the terminal like

cp -R /Volumes/vlc-2.2.1/VLC.app /Applications/

and voila, after that I could also open it from within the Applications folder. Please note the "-R"-option.

I think this is safer than allowing malicious files to be executed by disabling Gatekeeper.

  • This worked for me as well. Thanks for the tip. I suspect this is somehow bypassing gatekeeper, but since I didn't want to disable it altogether this seemed like a good work around until the VLC folks can fix the issue. – James McMahon Nov 18 '15 at 16:37
3

Option 1: Go to "System Preferences" -> "Security & Privacy" -> "General" For "Allow apps downloaded from:" choose "Mac App Store and identified developers" Then you should be able to right-click open the application and confirm security exception.

Option 2: When opening the application a security warning came up saying application wasn't signed.

I went to security settings and it had selected VLC ready for me to approve security exception for VLC, which I did.

VLC now works with El Captain.

P.s. I tried the "control-open" but unlike Mavericks, that didn't allow the application to start.

  • This doesn't work for me. Still get no option to open the program. – James McMahon Nov 18 '15 at 15:55
  • This doesn't work for me either. It doesn't show up in the Security & Privacy window. – Trevor Sullivan Nov 20 '15 at 18:52
2

Also make sure you are downloading the legitimate version of vlc

There is some nasty malware going around, actually the first link on google when you search VLC is false, make sure you are downloading from the actual VideoLan website and not filling your computer with nasty viruses (yes even mac users).

  • This should be the accepted answer. I originally downloaded from cNet and OSX didn't recognize it as being from an "identified developer." Download from here (I used Safari) and you're able to open it with right-click > Open. – brentonstrine Mar 7 '16 at 15:16
2
chown -R root:admin /Applications/VLC.app

Gatekeeper will not get in the way.

  • This is a great fix, cheers :) – sofly Feb 7 '16 at 18:50
1

In system preference, under security and confidentiality, check the box saying something like "allow downloaded apps from anywhere". If the box is greyed out, click on the lock at the bottom left corner and enter your password.

  • 1
    I caution against this option because disables security against running untrusted applications. All your favourite applications can still be run when choosing security option "Mac App Store and identified developers". Just the first time you run an application you need to explicitly allow it, which is much safer than running anything. – nslntmnx Nov 9 '15 at 23:58
0

Download VLC from Safari (not Chrome)

0

In my case, after upgrading to El Capitan, VLC crashed unconditionally a couple of seconds after opening any media. It was not a security issue because I have Allow apps downloaded from: anywhere in system settings. Happened both with the latest official version downloaded manually from the videolan.org or via homebrew.

The fix was building manually from git according to the instructions at https://wiki.videolan.org/OSXCompile (section Build VLC with a single command):

git clone git://git.videolan.org/vlc.git
cd vlc && mkdir build && cd build
../extras/package/macosx/build.sh

NOTE: You'll need Xcode and xcode command line tools .

The git version plays some media files but crashes with video streams which worked fine before the El Capitan upgrade. Hopefully they will fix this soon.

  • Hi @ccpizza. Please reword your answer so that it answers this question, or remove answer if not possible. – nslntmnx Jun 20 '16 at 3:24
  • @nslntmnx: the original question is a subset of a more general question which is VLC not working (properly) on osx. Many users will run into this thread by searching for e.g. vlc osx problem el capitan and not what you have in the original title. – ccpizza Jun 20 '16 at 15:01
-1

For future reference, you can open unsigned apps without a trip to settings if you know what you're doing: Right click on the application, and select 'open'. It will still give you a scary dialog, but with an option to open the app.

I haven't had a chance to test this on El Cap, so I'd be interested to hear if this still works.

  • 1
    Hi @Undo the "right click open" didn't work for me in El Cap. It was the first thing I tried as I used it all the time in Mavericks. – nslntmnx Oct 5 '15 at 4:00
  • Can confirm that this no longer works in 10.11.1 (El Cap). – James McMahon Nov 18 '15 at 15:57
  • Correction, this doesn't work for VLC. It does work for other applications. Most likely due to VLC's signing issues. – James McMahon Nov 18 '15 at 19:41
  • @JamesMcMahon Ah okay, that makes sense. I was testing it on other apps (I don't run VLC) and couldn't figure out why it was working for me but not for everyone else. Thank you! – Undo Nov 18 '15 at 19:48

You must log in to answer this question.

protected by Community Jun 1 '16 at 9:49

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .