3

My 2017 MacBook Pro's Wi-Fi completely stopped working. It's an issue with the Mac because it used to connect to the Wi-Fi just fine, and my phone is still connected to it.

I upgraded from macOS High Sierra to macOS Mojave yesterday, but it still worked then. Today I un-installed Parallels, and immediately afterwards the Wi-Fi stopped working.

How do I reenable the Wi-Fi?

  • Welcome to Ask Different :) Can you go to System Preferences app → Network and see if Wi-Fi is listed in the sidebar on the left? – Nimesh Neema Jun 15 at 9:06
  • It is listed there, and various wifi networks are recognized. However they can't be joined to. – nodwj Jun 15 at 9:11
  • Click on the lock in the bottom left to unlock Network preference. Select the Wi-Fi item in the sidebar, and click on Advanced... button shown in bottom right. Now under Wi-Fi tab (first tab), select and delete the access point. Dismiss the sheet and re join the access point. – Nimesh Neema Jun 15 at 9:14
  • I removed the access point and when I try to connect again , this time prompted to fill a password, after I enter the password the connection still fails. I also tried to connect to my phone's hot spot but nothing works. – nodwj Jun 15 at 9:25
  • Next you can try by removing all Wi-Fi items from sidebar, and re-adding it clicking on the + button at the bottom. Also try restarting if it doesn't work. – Nimesh Neema Jun 15 at 9:33
2

I found that the problem actually stems from the usb c dongle. USB-C Dongles killing Wifi on 2016/2017 MacBooks – Who’s to blame?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .