10

I am running macOS Mojave 10.14.4 with Books.app version 1.18.

I use multiple desktops. When I open the Books app on one desktop, and then switch to another desktop, the Books app window shows on that desktop as well.

Even worse, any open Books app window pop in front of all other windows on that desktop.

I've tried assigning the Books application to a specific desktop, to all desktops and to None, and did not see any change in behavior.

This only happens with the Books app on my system.

enter image description here

What may be potentially causing this? How can I keep Books app window restricted to a single desktop?

8
  • 1
    I don't use Books, but I just ran a test. At default, though it showed as 'None' it did follow me. Once I set it to 'This Desktop' then it stopped following, & after setting back to 'None' it then stayed where I put it.
    – Tetsujin
    Apr 13, 2019 at 13:50
  • This works when opening the "Library". As soon as you open a specific book and assigning it to a specific desktop, the books still follows you around...
    – jottr
    Apr 13, 2019 at 14:42
  • I tested with a book open. I can't repro your issue, sorry.
    – Tetsujin
    Apr 13, 2019 at 15:05
  • 1
    Thank you for trying @Tetsujin.
    – jottr
    Apr 13, 2019 at 15:20
  • 2
    Hmm... I thought I'd have another look. Every launch I have to repeat the 'this desktop', then 'none' again, or it follows me.
    – Tetsujin
    Apr 13, 2019 at 15:25

1 Answer 1

6

I had the exact same problem, solution:

  1. Open a book within the app

  2. Right click on the dock icon

  3. Options>Assign>This Desktop

Solved on macOS Catalina 10.15.4

1
  • This isn't a permanent solution because (as noted in the comments on the main question) every time you launch the Books app you have to repeat the steps (setting it to None and back to This Desktop) to get it to stop following you. May 31, 2021 at 5:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .