1

Running Mavericks (recently upgraded from Snow Leopard) I have three apps open on three of my 5 desktops -- Safari on desktop 1, TextEdit on 2, and Calendar on 3. I right-click on each icon in the dock on their respective desktops, and check Assign To This Desktop. I can right-click again any number of times to verify that that option is indeed checked. I can Cmd+right and Cmd+left across them, or Cmd+<number> to jump to the numbered desktop, and everything works fine. In particular, the apps stay where they're supposed to.

But now I try to use Cmd+Tab to switch apps and the desktop choice gets changed. Using the example above, if I'm on desktop 3 looking at Calendar, and Cmd+Tab to Safari (which should be on desktop 1), Safari gets pulled over to desktop 2, while TextEdit gets pushed to desktop 1 (and I get taken to desktop 2). The same sort of behavior happens with more apps and more desktops. Basically, the desktops get shuffled so that the Cmd+Tab app is closest.

I have no extra monitor or anything else unusual that I can think might be screwing anything up.

Is there any way to permanently assign an app to a particular desktop and/or turn off this terrible shuffling behavior?

3

The apps are not being moved to different desktops, but the desktops are being rearranged. To see the difference, put two apps on a space, then Cmd-Tab to one of the apps. You will end up in a space that contains both apps, although the space will have been renamed and shuffled in the order.

To stop this,

  1. Open System Preferences
  2. Go into Mission Control
  3. Uncheck Automatically rearrange Spaces based on most recent use

Mission Control with Automatically rearranges Spaces based on most recent use

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .