0

Mac OS 10.14.3 [Mojave]:

QuickTime Player is set as the default app for Finder's "open with" for .mp4 files on my Mac. This is what I want. But when I double-click an mp4 file, the kid3 app [a tag editor] launches instead of Quicktime Player!?

Why and how is kid3 invisibly hijacking the default app for "open with" for mp4 files? I found nothing related to this in kid3's preferences.

  • hello frogola! Please go to "get info" of the file and check the app it is to be opened with. – ankii Mar 9 at 19:06
  • @ankiiiiiii From the question, it sounds like macOS is ignoring that, which is a phenomenon I have experienced as well. Individual files always respect my preferences, but types of files sometimes don't, even when Change All is used. – Wowfunhappy Mar 9 at 19:21
  • Could you edit this - instead of “it’s not working” perhaps say what exactly you want to happen and what exactly happens. There are quite a fre questions, so maybe I’m just missing things and you could remove all the questions except for one final summary of what you want to achieve? – bmike Mar 9 at 19:25
  • @bmike I thought this question was pretty clear? Frogola wants mp4 files to open in QuickTime Player, but they are opening in kid3 instead, even though the get info lists QuickTime Player as the default. – Wowfunhappy Mar 9 at 20:17
  • Your answer is good - let's let to be open in case someone else wants to answer. Of course if your answer covers it / close or open doesn't mean anything since there's no need to add a second answer in that case. – bmike Mar 9 at 21:12
1

I sadly cannot explain this phenomenon. However, here is a hacky workaround that should resolve the issue:

  1. Right click the app you do not want to open mp4 files, and select Show Package Contents.

  2. Navigate to the Contents folder and locate the Info.plist file. Make a backup copy of this file, then open the original in TextEdit (or a similar program).

  3. Locate the section which resembles the below, and delete it. Save and close the file, and reboot your computer with "Reopen windows when logging back in" disabled.

<key>CFBundleTypeExtensions</key>
<array>
    <string>mp4</string>
</array>

Replace mp4 with whatever file extension you don't want the program to open.

I've never used kid3, but this successfully prevented Fission from opening mp3 files by default, as opposed to QuickTime.

(I think you might need to bypass Gatekeeper the next time you open the app? Not sure.)


If the file looks like gobblygook: close TextEdit, open the Terminal, type "plutil -convert xml1 " (without the quotes, but with a space at the end), drag Info.plist into the terminal window, and press enter. Info.plist should now appear correctly in TextEdit.

A reboot is not strictly necessary, but serves as a quick and definite way to force macOS to recognize the change. If you don't reboot, you will have to wait some (undeterminable) amount of time for your change to take effect.

  • Thank you for your detailed procedure. Unfortunately the behavior is unchanged. I did not delete the entire CFBundleTypeExtensions section, rather just deleted the mp4 string entry within. I will try deleting the entire section next and let you know if that works. Not sure if Gatekeeper is an issue [and not sure how to tell]. – frogola Mar 10 at 1:57
  • Deleted the entire CFBundleTypeExtensions section and behavior is still unchanged! So I did a find on Info.plist in the app's folder and discovered, in addition to the one you asked me to edit, 11 more in Contents/Frameworks/QtWhatever.framework subdirectories. So I will need to search all of those for similar sections I suppose. Will do that later and get back to you. – frogola Mar 10 at 2:10
  • @frogola Oh well, I'm sorry it didn't work, it was worth a try! If you're willing to spend time on trial and error, there is something in those plists causing the file association—everything is controlled there. Know that Gatekeeper isn't the problem unless the app outright refuses to open (but that a malformed Info.plist can also prevent an app from opening). – Wowfunhappy Mar 10 at 2:18
  • Also, be aware—when I was editing the plist for Fission, I originally removed the supported file type sections completely. This caused Fission to refuse to open any files, even manually, which is why I recommended just removing the file extension... – Wowfunhappy Mar 10 at 2:21
  • I grepped all the additional plist files and none of them contain 'mp4' so I don't know what to try next. Will probably sleep on it. I did copy the original plist before removing the associations so I can always restore it if necessary. Thanks anyway. – frogola Mar 10 at 4:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .