I regularly watch videos at 1.7x and would like for that preference to be saved across different videos instead of needing to manually reset it each time.

Is there such a setting for QuickTime for macOS? Alternatively, any other player capable for playing MP4 files with such option?


VLC for macOS is the video player you are looking for. It includes support for wide variety of audio and video codecs. Get the latest version from the download page or install via Homebrew by running:

brew cask install vlc

Once installed, open VLC Preferences by going to VLC → Preferences in the Menu bar or using the keyboard shortcut Command + ,. Click Show All button in the bottom left corner of the preferences window, click on Input/Codecs item in the left sidebar, and set the desired value for Playback speed. Once entered, click on the Save button in the bottom right to finalize your changes.

enter image description here

The playback speed will now persist for any subsequent media file that you will play.

Alternatively, if you do not wish to have a persistent speed setting, and wish to tweak it while a audio/video file is playing, do so in realtime via Playback → Playback Speed VLC Menu bar item.

enter image description here

| improve this answer | |
  • 3
    Even after installing vlc I would never have found that setting without your detailed dialog screenshots. Thank you. – javadba Sep 10 '18 at 15:45
  • hmm.. after setting to 1.75X and opening an .mp4 it is running at regular 1.X speed. I re-opened the dialog and it does show 1.75x. This is strange. – javadba Sep 10 '18 at 15:47
  • 1
    @javadba Most likely some other issue. It appears to work fine for me. (macOS High Sierra 10.13.6, VLC 3.0.4). – Nimesh Neema Sep 10 '18 at 16:09
  • 1
    Found out the reason: this is a work computer and they have disallowed "Open Apps from Unidentified Developer". I will need to use the VLC-specific Open File dialog instead of `Finder. – javadba Sep 10 '18 at 16:28
  • 1
    Unrelated: I really appreciate your very helpful edits! – GhostCat Apr 9 '19 at 18:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .