1

I have a probleme with my iMac, it won't recognise the jack headphones when I plug it in. When plug-in, in system and preferences, I'm not able to see the jack output.

have tried the folowing method however it doesn't work.

The only technique that works for me is to reset NVRAM or PRAM on startup

However, if my iMac go in sleep mode the bug comes back.

Any one has a solution that works along time? Commande line to reset NVRAM or PRAM? App that can correct this issue? Manip?

Here is my iMac :

enter image description here

I had this bug since Mavericks, help please !!!!

DCPIManager

I have installed it however, what do i have to perform here? Cf screens with jack headphone connected.

DCPIManager enter image description here

Thanks


Thanks a lot for your help :)

New tests after NVRAM reset -> I can here sound from my headphones

Here are new screenshots

enter image description here enter image description here enter image description here

I can't see any difference on DPCIManager when headphones works !!!

When I put the iMac on sleep and re-launch my session, headphones stop working... I went on DPCIManager, I have exactly the same screens as above. Let me know what I can do to give you more informations. Thanks again for your help, very appreciate it

------------------------

NEW tests.

I have installed Clover and did exactly what you said (checked everything, EFI > EFI > CLOVER > config.plist (resetHDA was already checked)) I have restart the computer (without PRAM reset) I have sound on my headphones !!!!! However, when I go back to sleep mode & start a new session, headphones are still not working...

I went back on CLOVER -> devices tab, here is what I can see:

enter image description here

Did I have missed something? Do I need to update ResetHDA?

Thanks

  • I had a similar issue with several versions of macOS. If you are certain the jack itself works my recommendation is to install an alternate audio driver that will properly detect your devices. It requires getting a little involved with the software on your machine, but nothing too intense. Please download and run DPCIManager, and attach the Codec Name* as listed in the audio tab to your question. – Alison E.E. Feb 13 at 21:39
  • If you have a free USB slot you can purchase an inexpensive USB audio adapter to handle audio I/O. Behringer makes one which I use on an older iMac with a broken jack. – IconDaemon Feb 13 at 22:42
  • Hey @AlisonE.E. I have installed DPCIManager, but i wasn't able to attach the codec, do you have a link ? Thanks :) – Romain Feb 18 at 12:23
  • @Romain If the ResetHDA checkbox in Clover Configurator is unchecked after doing a sleep/wake cycle, you will need to check it, and save the file (Command-S). After that try rebooting the Mac, checking sound just in case, and if everything works do another sleep/wake and see if sound is working/ResetHDA is still enabled. Again sorry for the late response, I was out of town for a few days. I will be bringing a laptop with me when I go out from now on. – Alison E.E. Mar 9 at 5:54
1

I noticed from the screenshots you attached that there doesn't seem to be any audio device installed, as far as macOS is concerned. This is the category I expected you to find:

Correct DPIC

You'll notice it lists ALC892 under Codec Name*. This is the codec used by the audio chip in my Mac. Knowing your codec would allow you to choose and install a 3rd party driver for your audio chip, and in my case this was enough to fix the issue of no output device appearing on one of my Macs. Upon further consideration however, this may not be the root issue.

I would recommend you do an NVRAM reset, if that will allow the output device to show up. Check the application again after doing so, and if the category is present take another screenshot, or write down the listed codec. Then put the machine to sleep, wake it, check if the output device is gone, and check DPCIManager to see if the category/entries went with it. Also repeat the process, and try rebooting the machine rather than sleep/waking it to see if that causes the output device/DPCIManager entry to disappear.

If it is not present after waking/rebooting the machine, the issue is most likely one I experienced on another one of my Macs, that being that the HDA (High Def Audio) handler is not loading when the machine boots/wakes from sleep.

If it is an HDA handler issue, which it sounds like it may be based on your description, the only option I know of is to install a 3rd party bootloader that is capable of emulating your Mac's NVRAM (like Clover UEFI), and configuring it to manually reset the HDA handler on every boot/wake.

The bootloader method is rather easy to set up, and I managed to fix the HDA handler on one of my Macs failing to load at boot that way. It is a bit of an involved process, but I can give you a step-by-step if you decide to go that route.

Please be sure to update your question with any further information you find, and I will update my answer accordingly.

UPDATE: In the first of your new post-NVRAM-reset screenshots I can see that your audio chip is registered and that the codec it uses has full macOS support. This confirms my theory that the HDA handler is failing to reset on reboot or wake. As I mentioned the only fix I am aware of for this issue is to install a 3rd party boot loader that can manually reset it on every boot/wake. I'll detail the steps to do so below.

In this example I will be using the Clover EFI boot loader, as it is my personal choice when I need to use a 3rd party loader, and is the one with which I have the most experience.

1.) Grab the Clover EFI installer from here.

2.) Run the installer (Right Click>Open), go through the pages, and click Customize when you get to this window: Clover Standard

3.) Check the following boxes:

*Clover for UEFI booting only
*Install Clover in the ESP

Under UEFI Drivers drop-down

*AudioDxe-64
*DataHubDxe-64
*FSInject-64
*SMCHelper-64
*VBoxHfs-64
*ApfsDriverLoader-64
*AptioMemoryFix-64
*EmuVariableUefi-64
*PartitionDxe-64
*Ps2MouseDxe-64
*UsbKbDxe-64
*UsbMouseDxe-64
*VBoxExt2-64
*VBoxExt4-64

Under FileVault 2 UEFI Drivers drop-down

Everything

*Install RC scripts on target volume
*Install Clover Preference Pane

4.) Double check to ensure everything listed is checked, and nothing that was not listed is checked. Once you have done so click the Install button.

5.) Download the Clover Configurator from here.

6.) Once it has been successfully installed, open it, and at the bottom of the screen click the path that reads EFI > EFI > CLOVER > config.plist. Configurator Plist

7.) Now go down to the Devices tab, and in the top right corner check the box labelled ResetHDA if it is not already. Make sure not to change any other options in any of the tabs. When you are done hit Command-S to save the config (only if you had to check the box, if it was already checked you are good to go.) Clover Devices

8.) Reboot your machine. Once you have gone through Clover and booted back into macOS your audio output should be working fine, and the chip/jack should show up in DPCIManager and System Preferences>Sound>Output respectively.

I have encountered this issue on multiple Macs, both official and Hackintosh alike, and this has consistently been able to resolve the problem. If you need any extra details or if something goes wrong, just let me know.

  • Hey @Alison E.E. I have done news test but without any luck :/ Any new idea? thanks for your help – Romain Feb 22 at 11:11
  • @Romain I have updated my answer with steps to set up a boot loader that will reset the HDA handler on each boot. This should be enough to get your audio devices working without needing to do an NVRAM reset every time you restart. Sorry for the late reply BTW, I was out of town for the last week and didn't have any of my computers with me. – Alison E.E. Mar 3 at 1:20
  • Thanks a lot for your help and don't worry about your late answer, you are helping and I really appreciate that :) Still have this issue, ask me what else I can provide to you, I will deliver it :) – Romain Mar 4 at 12:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .