1

I have a MacBook pro running macOS Sierra.

All of a sudden the Apple Mail program started filtering messages. I know that they are there in my inbox but I can't see them. When new mail comes, it's there for a bit but then disappears from view. I know it's there because I can search for it and find it.

How can I turn off this filtering???

I don't use gmail, just the Apple program with our local email provider. I have restored macOS and rebuilt the inbox several times. At one point I saw there were multiple copies of the same emails from the day this problem started.

  • Is you provider using POP email by any chance? -- All the best. – bret7600 Jan 15 at 23:58
  • Welcome to Ask Different! :) I hope you come to find this site has a lot to offer! In case you haven't already, it's worth taking the time to read the tour. All the best! – Monomeeth Jan 16 at 0:08
1

Sounds like you may have accidentally turned on the Message Filter, which hides read messages by default? If so, you can turn it off again with View>Disable Message Filter, or hitting Cmd-L.

(I only found about this feature a couple of years ago when I accidentally turned it on in the default layout, then switched back to Classic layout. At that time, the filter setting carried over, but there was no indication that the filter was turned on. In High Sierra, it appears they've avoided this problem by disabling the filtering capability in Classic layout.)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .