• MacBook Pro (Retina, 15-inch, Mid 2015)

  • macOS Mojave v10.14.2

  • chrome version 71.0.3578.98

  • safari version 12.0.2

Using this website I can see the line but it isn't moving. The problem occurs on both chrome and safari. However, in safari the line doesn't even appear.

  • My google chrome settings are set properly (i.e. allow on request and no sites blocked)
  • I have attached a screenshot of my sound input settings
  • I have tried installing and uninstalling chrome
  • Microphone works fine on photo booth, skype and slack

enter image description here

  • Did you allow access to the mic for the page you're accessing?
    – fsb
    Dec 30, 2018 at 18:18
  • @fsb yes I have.
    – Ludo
    Dec 31, 2018 at 12:46

2 Answers 2


Chrome wasn't allowed to use my microphone from the security settings in MacOS. Maybe this setting was lost after the update to Mojave?

  1. Goto 'System preferences'
  2. Click on 'Security & Privacy'
  3. Click on the tab 'Privacy'
  4. Select 'Microphone' from the left sidebar
  5. Make sure 'Google Chrome' is checked
  6. Let's celebrate, it's working again
  • 3
    Unfortunately chrome isn't in the list for me :/
    – crgarridos
    Dec 20, 2019 at 12:00
  • This security setting is new in Mojave, which is why you started having the problem after updating to Mojave.
    – Nic
    Mar 14, 2020 at 0:47
  • @crgarridos Check out How do I configure Camera and Microphone permission on macOS Mojave?
    – Nic
    Mar 14, 2020 at 0:48
  • Thanks @Nic It wasn't that, but thanks to you I remember I had SIP enabled. disabling it did the job ! thanks again
    – crgarridos
    Mar 16, 2020 at 9:44

I was months looking for a solution and anone of them worked for me. Apps simply didn't ask for permission. Then I remembered that I had disabled SIP(System Integrity Protection). Re-enabling does the job!

Check if SIP is disabled:

$ csrutil status

If you get System Integrity Protection status: disabled. We have to re-enable it.

Restart your Mac in recovery mode:

Before OS X starts up, hold down Command-R and keep it held down until you see an Apple icon and a progress bar. Release. This boots you into Recovery.

In recovery mode, Utilities menu, select Terminal and execute:

$ csrutil enable
$ csrutil clear

Reboot and the apps should ask again for every permission.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .