2

Hey so I feel really dumb asking this, but I cannot figure out why my internal mic on my 2011 MBP recently stopped working.

Here's what I've tried:

  1. Zapping the PRAM

  2. Resetting the SMC by "Using the built-in keyboard, press and hold the Left Shift, Command, Option and Power Button at the same time."

  3. Quadruple checked audio settings: built-in mic, audio up, not muted, voiceover off, detected by plugins, and so on.

  4. Everything's up to date

  5. Disk permission and everything are good

I feel like I've done more than that too. I can't figure it out. I've also tried using Skype, Garage Band, and other microphone accessing apps - none detect sound. It was fine about 2 weeks ago when I used Skype and FaceTime.

Any suggestions will be greatly appreciated. Thanks!

3

This happened to me the other day. After checking all the obvious settings etc. It actually seemed as if there were either no drivers or the actual hardware had been removed, like the OS didn't acknowledge its presence at all. I spent ages trying to work it out and what got it working again was just plugging something into the 3.5mm TRRS audio input/output jack on the side.

1

Just checking the obvious, is your internal mic the input device?

option+click the volume button in the menu bar and look down the list, make sure internal microphone is selected as input device.

0

When I have this, it’s because I didn’t seat the adapters. Things now working on all my apple devices. I had to ensure that the adapter was pushed in all the way since it has 3 ridges.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .