3

First-timer here.

I have been experiencing several serious-looking problems with my MacBook (OSX Yosemite 10.10.5, model MacBookPro10,1: Mid 2012 Retina, 16GB RAM, 768GB SSD) for a while now, the major of them being unable to restart, shutdown or log out normally. What happens is, after quitting every app, the system is left idling at the empty desktop — no icons, no menu bar, just the wallpaper. The mouse pointer is movable, Dock and Spotlight are still operating, but Finder is «Not Responding» and unable to relaunch in any way. So all I'm left with is a hard Power button reset or sudo shutdown -h now (another workaround is to click Restart with admin rights on the login window, I presume it's the same as the terminal command).

This problem is accompanied (and may or may not be caused) by many others:

  • Certain apps may refuse to quit against all measures as well, thereby hanging out in the Dock and halting the shutdown
  • Quick Preview (handy Spacebar thing) is showing nothing but empty white rectangles
  • Preview itself opening all files as empty windows or practicing other weird behaviours like not showing the pixel selection frame
  • Finder throwing up a self-conscious «The application “Finder.app” is not open anymore» in response to launching apps or opening windows through Spotlight (even though ⌘-Enter to show file location still works)
  • Folders appear to be empty until Finder is relaunched (manually or by itself)
  • Unable to launch some apps, notably Photos
  • Minor rare cases of graphics corruptions, like garbled windows in Mission Control

All of these get fixed by a Mac restart, but keep steadily accumulating again. It's like the more time elapses after a restart, the more ruined and deteriorated the system becomes.

What I tried:

  • Resetting NVRAM
  • Resetting the SMC
  • Performing an extended Apple Hardware Test (no issues were found)
  • Verifying hard drive and repairing disk permissions
  • Booting in Safe Mode (where everything gets super slow; the problem persists)

For a positive note, this whole situation has taught me to do frequent Time Machine backups, but I would like to leave OS reinstallation as a last resort. (My drive is partitioned into two, with Windows 7 installed through Boot Camp, if that has significance.) I know that Yosemite is quite old, but I'm honestly scared of upgrading lest it becomes worse (performance loss, new glitches, feel free to reassure me).

So, could anyone provide tips on what the root of this problem may be and how to fix it? Logs I should check, tests I can do, files to wipe or redact? Any advice is appreciated. Thank you, and safe travels!


Update 1:
I have tried booting into Safe Mode once again, acting out some generic work and having a look at the Activity Monitor. Here is what it looks like:

Activity Monitor within Safe Mode

Interestingly, the computer seems to shut down properly from Safe Mode. Once again though, some window animations are extremely slow to render here, producing beautiful scrolling lines.

Then, I booted normally and did roughly the same manipulations. The Monitor from here:

Activity Monitor within normal boot

I also tried shutting down in normal mode immediately after landing on the desktop after a restart, which works. So one can assume there is a software gimmick that is causing this problem shortly after startup.

Update 2:
I created a new Standard (non-Admin) account as was suggested, and I think that helped to uncover the exact criminal in disguise — Finder. It seems like everything works nicely (while launching and switching apps), until the first Finder window is open (any folder), which somehow makes Finder unresponsive on shutdown, thereby freezing the latter. This happens on both user accounts. Interestingly, switching to another user and doing a «proper» shutdown (from Apple menu) before using Finder is working (although I guess the «blocked» user's session is still halted abruptly and incorrectly then).

Now, the question is: what exactly is wrong with Finder, and how can I help the little guy?

Update 3:
As suggested, I tried moving Finder cache and preference files to desktop through the Terminal while logged in as a different user, but this doesn't seem to affect the problem.

I could find no crash logs for Finder apart from some short diagnostic reports, and noticed nothing unusual displayed by the Console while the faulty shutdown is in process, but here is an example of some fishy Finder-related events which may be happening during uptime:

Fishy Finder-related messages in Console

(I do not know how significant these are; the Console spits out things like that from various processes regularly).

  • 2
    I know you've tried booting into Safe Mode, but what happens if you create a totally new user account and log into that? Also, how much free space do you have on your SSD? – Monomeeth Oct 24 '18 at 23:06
  • can we see your CPU usage in Activity Monitor ? is that the original battery – Ruskes Oct 24 '18 at 23:52
  • Get a 16GB (or larger) USB flash, install a clean copy of macOS to that, boot from it and evaluate your performance. If the problem goes away, it points to a reinstall as your fix. – Allan Oct 25 '18 at 3:55
  • A reinstall from Recovery is pretty 'safe' - overlays a new OS on top of the old one without breaking things. Having a backup is wise, of course, but you shouldn't need it. – Tetsujin Oct 25 '18 at 6:22
  • 1
    You can install any version of macOS, but Yosemite is quite old, I would go with something newer. It won't break anything because you will be installing on the 16GB Flash and not touching your drive. With that said, make sure you select the flash disk when you you are prompted in the installation screen. – Allan Oct 25 '18 at 13:27
1

I think installing new OS X is premature at this time and should remain as option.

But it looks like you have problems with some 3D party apps.

What is https //vk.com/ ?

To test... Log in as Different user and see if it works to confirm my assumption.

You can also run the EtreCheck to get a report on your system.

And disable any app launching at start up in user profile log in items.

More investigation...

To find out what the Finder is doing use following in Terminal.

sudo log show --start "2018-10-26 13:45:17" --end "2018-10-26 14:45:47" --info --debug --signpost | grep -i Finder

Adjust the date/time accordinaly

  • I have tried making the new user, and I think Finder may be the main culprit after all (more info in the post update). I have no login items listed except for iTunesHelper on the Admin account (even though some programs like the anti-virus still load with the system all the time). VK is a social network website open in a Safari tab, so I presume it shows up in the Monitor just as any other web content like YouTube or Stack Exchange. – Jerry V Oct 25 '18 at 18:44
  • Hmm, it says sudo: log: command not found. I tried looking for log files manually, but found none (maybe I don't know where to look). I spied some suspicious messages from Finder in Console though – screenshot in update. – Jerry V Oct 27 '18 at 13:31
  • @JerryV I just tried it again and it works perfectly, it does ask for you Password. Just copy paste exactly as is in my post. Let me look at you console finds. – Ruskes Oct 27 '18 at 14:58
  • That's the thing—it does ask for a password, but after that it says command not found and nothing else. Typing man log brings me to the man page for builtin shell commands, among which log is listed, but I can't find a description of this particular command anywhere. I posted a screen of some Console messages I noticed, but I'm not sure if they're relevant or where else to look for logs on the matter. – Jerry V Oct 30 '18 at 12:22
1

Here's what I would try:

  1. Login as your 'other' user.

  2. Launch Terminal.app

  3. Type login shortname (where shortname is the username that is having problems with Finder) and enter your password when prompted. (Then type whoami to verify you are logged in the correct account.)

  4. Run these commands:

    mv -v ~/Library/Caches/com.apple.finder/ ~/Desktop/
    
    mv -v ~/Library/Preferences/com.apple.finder.plist ~/Desktop/
    
  5. Log out as your 'other' user.

  6. Log in as shortname as usual.

All of your Finder preferences will be reset to the defaults, but it might solve your problem.

  • Thanks for the suggestion — I tried this out, but it doesn't seem to help. – Jerry V Oct 27 '18 at 13:35
  • Rats. I was hopeful. – TJ Luoma Oct 27 '18 at 18:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .