0

I'm desperately trying to fix the issue which doesn't let my MacBook Pro restart/shutdown properly. When I click on restart or shutdown, it gets stuck when the display gets black (but still slightly on, also keyboard lights are on) forever (once let it try to restart/shutdown the whole night).

When I bought the mbp, it was El Capitan installed. I've upgraded to Sierra (now 10.12.3) and then problems started, but I'm really not if it happened right after the upgrade or sometime later.

After booting into safe mode, restart/shutdown works.

Things I've tried so far:

  • close/force quit all apps before restart/shut down
  • relaunch finder before restart/shut down
  • removed all apps from login items
  • tried another user profile
  • ran "First Aid" on Disk Utility
  • restart/shut down works after booting into safe mode
  • reseted SMC
  • reseted NVRAM
  • ran Apple Diagnostics (no issues)
  • ran cache clearing commands:

rm -rf ~/Library/Caches/*; rm -rf ~/Library/Saved\ Application\ State/*; sudo rm -rf /Library/Caches/*; sudo rm -rf /System/Library/Caches/*; atsutil databases -removeUser; sudo atsutil databases -remove; sudo atsutil server -shutdown; sudo atsutil server -ping; sudo rm -rf /var/folders/*

  • deleted all printers
  • tried shutdown -r now
  • removed com.apple.finder.plist & com.apple.sidebarlists.plist
  • ran a system update so permissions are going to be repaired
-1

Fixing permissions on my drive solved the issue. I was able to find a solution on this Apple Discussion thread.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .