0

My system

I've read about a dozen similar questions to this. I'm running a 13" retina MacBook Pro and using El Capitan 10.11.6.

System is generally stable.

Model Name: MacBook Pro
  Model Identifier: MacBookPro11,1
  Processor Name:   Intel Core i7
  Processor Speed:  2.8 GHz
  Number of Processors: 1
  Total Number of Cores:    2
  L2 Cache (per Core):  256 KB
  L3 Cache: 4 MB
  Memory:   16 GB
  Boot ROM Version: MBP111.0142.B00
  SMC Version (system): 2.16f68

The issue

Annoyingly the same time I went abroad for several months in a region with no Mac stores without taking several flights and unreliable internet access, the system has basically stopped working.

Well, anything to do with Finder doesn't work. Any time you open a new tab or window it freezes (goes Not Responding) in Activity Monitor and Dock. I get spinning beach ball for 10+ minutes but it usually recovers eventually.

Relaunching or Force Quitting doesn't help at all. There is no CPU spike or anything like that.

Other apps freeze/crash/go Not Responding on start too and never seem to recover. Every single time I try to use BetterTouchTools, TextExpander, Excel or uTorrent they cannot run. I suspect it is related to the more fundamental Finder issue. Weirdly, Word will run fine as will Transmission.

Just tried installing Commander One as an alternative. Hang immediately on opening too.

I put some crashlogs on Dropbox if somebody wants to have a look: CommanderOne, Excel, uTorrent.

What I've tried

  • booting into safe mode to reset Finder settings
  • resetting SMC
  • HDD benchmarks and SMART info is fine
  • killing Google Drive
  • Nothing obvious in system.log
  • mv ~/L*/S*/*finder.savedState Desktop followed by killall Finder

Edit: also tried restoring from several Time Machine backups as far back as November and the symptoms persist. Wtf is this????

HALP?!

  • 1
    All three crashlogs seem to be related to file access. Did you have an external drive (or network share) attached at home (or any time before the crashes started to occur)? Can you boot into safe mode again and run fsck on the disk (to see whether it's slowly failing, SMART doesn't help a lot here)? – nohillside Dec 23 '18 at 19:35
  • Also, what do you mean by "System is generally stable"? From your question it seems that the system is far from stable currently... – nohillside Dec 23 '18 at 19:37
  • @nohillside - yes, I usually do have various network shares that are meant to automatically connect. I thought they would do this gracefully but it seems not as I have now done two Time MAchine restores with the same symptoms. What would be the best way to get around this? – Turkeyphant Dec 23 '18 at 22:09
  • I use autofs to keep network drives connected as per this guide: blog.grapii.com/2015/06/… It does seem that this is the issue but that sounds crazy - especially as it's a laptop, it seems mental that the whole system crumbles when a local network share is no longer available... – Turkeyphant Dec 23 '18 at 22:13
  • At the moment the network stuff is just a possible cause. Can you disable the automounter (just rename the config file) and reboot? – nohillside Dec 23 '18 at 22:18
0

How odd. But I solved it.

Of course, I lost about half my files with the system restores through Time Machine before I worked it out.

nohillside ♦ pretty much got it spot on. It was me using autofs to mount network shares. Quite why a network share going down or being unavailable means that the entire system is unusable is beyond me. It fact, thinking about it, it's utterly insane.

I wonder if now I have to write some really hacky script to automatically disable autofs if it can't connect to the server a few times in a row.

Another thing that I fear will remain an eternal mystery is why various other apps completely locked up and failed to start. Why TextExpander and BetterTouchTool? Why any file manager? Why Excel but not Word?!

TL;DR - how do I fix it?

Simply deleted the auto_nas file with:

$ sudo nano /etc/auto_nas

I kept the line in /etc/auto_master

0

Can you add 'nofail" like what fergaljd did? This is his post, and I also given some suggestion that you might want to try. Login problems with Automount and SMB shares

  • I'll give it a go but I'd like to know what "soft", "noowners", "nobrowse", "rw" do exactly before trying it. I can't find any resource that actually explains this. – Turkeyphant Apr 25 at 11:15
  • You can type man mount in terminal. Scroll down to the bottom of that page, you can further drill down to open manual for mount_smbfs for example. Some of the command might only work for NFS but not SMB for example. You can take a look this website for online manual, but you can always type it in the terminal for latest version. – Yudi Setiawan Apr 26 at 1:03
  • There's nothing I can see in any of the man pages about ,many of those options? – Turkeyphant Apr 26 at 13:25
  • Okay I tried it and now I can't even get automount to work (using the same auto_master and auto_nas I was previously). When the mount points are mounted they are blank and I can't cd into them. I have tried unmounting and rebooting with no effect. – Turkeyphant Apr 26 at 13:55
  • Do you mind to post your auto_master and auto_nas setting? It doesn’t mount but it doesn’t make your computer freezes, does it? – Yudi Setiawan Apr 27 at 0:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .