6

I am trying to play a QuickTime video in Lion on an external monitor. How do I get it to play full screen on the external monitor, not on the laptop screen?

2

Install QT 7 from http://support.apple.com/kb/dl923 and open your movie with QT7. Then open Preferences and select Fullscreen tab and click on your second display.

Update:
Movist is a great player. You can get it from here: http://code.google.com/p/movist/

  • Ah! I didn't think of that. I will try it out and let you know! – daviesgeek Jan 24 '12 at 17:12
0

Move the non-fullscreen QuickTime window to the external monitor, then click the fullscreen button.

Sorry, just tested and that doesn't work. It used to, not sure when that changed.

It's not a proper solution, but using VLC would be a workable stopgap measure - it doesn't use the built-in Lion fullscreen functionality, and thus can be put wherever you like, and doesn't blank the other screens at the same time.

  • Thanks for the answer, but it still doesn't fix QT player. – daviesgeek Dec 28 '11 at 3:34
  • That does work in Mountain Lion. – CyberSkull Dec 2 '12 at 6:08
0

The only way I can see fullscreen playing on a non-primary display (without editing System Preferences or adding additional software) is this:

  1. select movie file in Finder
  2. activate Quick Look (click the eye button or press space bar)
  3. move the Quick Look window over to the target display
  4. click the "expand to fullscreen" arrows button in its top right corner.

QuickTime Player Version 10.1 (501.8) on Lion - the Quick Look hack only works on non-streamed content so it is kind of a bummer. I seriously hope that Apple fixes this in a software update soon :-/

  • No, dear sales people, it will not trick me into buying and carrying around an AppleTV :-/ – conny Feb 21 '12 at 10:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .