4

When starting a new Screen Recording in Quicktime Player in Lion 10.7.3, as soon as I click record I get this following error message:

quicktime error

Here's a video demonstrating the issue: http://db.tt/CROyXgIt

Here are the settings under the triangle on the right:

enter image description here

8
  • Works fine for me. Just putting that out there.
    – Tuesday
    Commented Mar 30, 2012 at 0:00
  • May I ask, though, what's the input-bar-type thing between the O and N of operation? Also, there's usually correct punctuation in Apple's error messages (i.e. "The operation could not be completed." with a period). What's up?
    – Tuesday
    Commented Mar 30, 2012 at 0:02
  • 1
    The input-bar-type thing is just a cursor that appears if you click on the message. the message isn't editable or anything, though. When I take a screenshot, the main quicktime window disappears, even with a full screenshot - i.imgur.com/Lokhm.png?1 (that screenshot shows you can select text with the cursor thing)
    – penguinrob
    Commented Mar 30, 2012 at 1:02
  • Huh, never seen that before. OK!
    – Tuesday
    Commented Mar 30, 2012 at 1:14
  • @penguinrob What are your settings under the triangle on the right? Commented Mar 30, 2012 at 2:06

3 Answers 3

4

Finally figured it out - apparently the Movies folder in my home directory had a weird permission set on it and things couldn't be written to it, which caused QuickTime to give a very descriptive message "The operation could not be completed" and saving to a different folder (or after fixing the permissions on Movies), worked.

4
  • Don't forget to mark your question as answered !
    – Ermiar
    Commented Apr 30, 2012 at 11:04
  • What did you set the permissions to?
    – nipponese
    Commented Oct 12, 2015 at 20:50
  • @nipponese The permissions were set to "Read only" for my user account, so I changed it to "Read & Write" for my account in the Finder Get Info window, and then I could save to it.
    – penguinrob
    Commented Oct 13, 2015 at 3:40
  • 1
    doesn't work, permission «Read & Write», macOS: 10.12.4, QuickTime Player: 10.4, iOS: 10.3.1
    – OnengLar
    Commented Apr 22, 2017 at 23:34
1

Simply restarting my mac worked for me.

0

FWIW, I ran into this issue today and the problem was with the external monitor. After unplugging the Apple Display, I was able to see the phone screen output fine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .