10

When I record a screen with a standard QuickTime Player functionality, I get a completely green video. I'm using Mac OS X 10.8, Mountain Lion, and a Retina MacBook Pro 15".

Does anybody know what is the issue and how it can be fixed?

Green screen recorded with QuickTime on OS X

  • Do you have the DVD Player (or similar) running as well? – nohillside Apr 3 '13 at 8:53
  • @patrix no there wasn't anything like that, thou I can't reproduce it after rebooting :(: "I'm happy that it's working but I'm sad that the question can be investigated" – Uko Apr 3 '13 at 9:36
  • 1
    This appears to be a common problem on the 15" mbp-retina. Not really sure what qualifies as "localized." Hopefully someone will discover a solution soon. It occurs in both QuickTime and iShowU. Some have have reported success by forcing the resolution to "more space", but that doesn't work for all. – baldengineer Apr 12 '13 at 16:28
  • 2
    Well I was able to find a way to make screen recording work. If you download the "gfxCardStatus" utility, you can force it to use your internal graphics controller. This will allow for recording video. – baldengineer Apr 12 '13 at 20:10
  • 1
    Also, some users (and the Genius Bar) have reported that simply running "repair disk permissions" will solve this issue. However, that did not work for me. The only solution was to use gfxCardStatus. – baldengineer Apr 29 '13 at 15:29
3

Try the following:

  1. Turn off computer
  2. Reboot Mac into Recovery (press and hold Command+R when you hear the chimes until a screen loads)
  3. Select "Disk Utility" enter image description here
  4. Select your "Macintosh HD" volume on the left and press "Repair Disk Permissions" enter image description here
  5. Once that has finished, reboot your computer

If this doesn't work, call Apple Support

  • 1
    This worked for me, while the normal Repair Permissions in Disk Utility (without booting into recovery mode) did not. – Matt Ball Oct 25 '13 at 0:14
  • 1
    Worked for me. +1 – Andrew Ferrier Dec 17 '13 at 10:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .