I'm pretty sure I haven't changed any setting or installed anything other than software updates, but today I've started getting this dialog when I clicked a magnet link:

enter image description here

How do I get rid of this dialog? I've clicked okay once, but then I've clicked another magnet link and got the same dialog again. Why did it suddenly start and how do I get rid of Safari constantly asking about it?

I'm on macOS 10.12.2/Safari 10.0.2

  • 3
    Looks like macOS 10.12.2 Update caused this security setting in Safari. I swapped to Firefox to avoid it for now. Using spctl to sign Vuze didn't fix it. Commented Dec 28, 2016 at 21:50
  • 7
    I mean just once at the first time might be a good feature, but how is this even a "feature" when it repeatedly asks every time I use the same app on even the same site! Commented Dec 28, 2016 at 23:01
  • 1
    Same problem here. This seems to be a new security feature that doesn't have an obvious pref to turn it off, and the answer isn't "sticky": it asks every time. We use this feature internally to launch FileMaker (with an "fmp://" URL) for our users via a URL, so this is disruptive and we'd like to turn it off, at least for FileMaker.
    – JohnEDee
    Commented Feb 6, 2017 at 20:43
  • 9
    @JakubSrnka of course it's a security settings and IMO it's a good one. However, constantly asking every time after the first one decreases user experience. Commented Nov 23, 2017 at 15:25
  • 4
    Has there been any workaround added to Safari since this was asked?
    – Dov
    Commented Jan 27, 2022 at 16:06

4 Answers 4


If the application you want to use is already running (or is in the dock), you can drag and drop the magnet link onto the application's dock icon to avoid the dialog.

There's also a discussion on the Transmission forum on this. The dialog that appears when clicking on such a link seems to be a Safari security feature that currently can't be disabled.


Use Safari 17+

Safari 17 will let you Always Allow a website to open an app.

enter image description here

Source: A screenshot of Safari 17 Beta by @ezekiel in How to open a Zoom link in a non-browser app without being prompted?. I was not able to confirm this feature in the Safari 17 release notes. Safari 17 was publicly released in Fall 2023 with this feature.


I have a set of interactive displays to control my entertainment center via calls on iRed. The change in Safari rendered these useless. I tried to circumvent the warning dialog but finally gave up. Until this warning can be avoided, I switched to the Vivaldi browser. It works perfectly and I'm able to use my entertainment center again without a multitude of remotes.


I was able to eliminate the message by treating it as an extension conflict.

  1. Safari > Preferences: Extensions.
  2. Disable all extensions and test.
  3. Reenable extensions one at a time, retesting after each one.
  4. Update or uninstall the conflicting extensions.
  • Are you sure you're talking about the same message as shown in the screenshot? I'm seeing the message even with Extensions turned off, and it doesn't seem to be Extension-related anyway...it's a core part of Safari. My guess is we'll need a "defaults write" way to turn this off, if such a setting for that exists.
    – JohnEDee
    Commented Feb 6, 2017 at 16:20
  • My solution works for me. With the Kablock! extension enabled, I get the annoying message in situations similar to the one you displayed. With it disabled, I don't. I lack the expertise to say more than that or speculate on why my experience might be idiosyncratic. Commented Feb 7, 2017 at 0:46
  • 1
    I see what you mean: some Extensions can trigger the same message by trying to open apps themselves. But this issue can happen without Extensions at all, simply by giving Safari a URL to open that the Mac associates with an application. An example is a "mailto:" link: although the dialog that Safari pops up is a little different, it's the same issue. For example, try a link like mailto:[email protected] in Safari and it should trigger the dialog. (I tried to create the link here in the comment, but can't get it to work). We encountered it with using FileMaker links, i.e. "fmp://"
    – JohnEDee
    Commented Feb 8, 2017 at 1:32
  • 1
    I have no extensions at all, so that's not the root issue. Commented Mar 6, 2017 at 11:44
  • I don't use any extensions at all. Commented Mar 20, 2017 at 22:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .