6

URLs have long been the domain of web browsers, but some apps challenge this assumption by asking your browser to open a link in their dedicated app.

Problem: Safari Keeps Asking Permission

For example, I use Zoom.us, a videoconferencing service. They give me a link associated with my conference call that's easy to throw into a calendar invite, like https://ibm.zoom.us/j/9747900418. When I click the link, my browser opens it, authenticates me, and asks me permission to open the link in Zoom.us.app, which I've already installed.

Dialog asking to open a page in zoom.us

After opening hundred of meetings this way, I'm sick of it asking me permission. I want Safari to remember that it's allowed to open zoom.us/* links in Zoom.us.app.

What I've Tried

Under Safari > Preferences > Websites, I escalated privileges for Zoom-related items:

  • General > Auto-Play > ibm.zoom.us was "Stop media with sound"; set to "Allow Auto-Play"
  • Plug-ins > Zoom Launcher 3.0.1 > ibm.zoom.us was "Ask"; set to "On"
  • Plug-ins > Zoom Launcher 3.0.1 > support.zoom.us was "Ask"; set to "On"

This had no effect. So how can I get Zoom links to open correctly?

1

I don't think it can be disabled...but...if the application you want to use is already running (or is in the dock), you can drag and drop the link onto the application's dock icon to avoid the dialog.

I just did it with a magnet link and Transmission and it did not invoke the dialog (I know, at the cost of a drag...which is...a drag).

  • Great idea (and nice pun), but dragging a link onto the application icon doesn't work with Zoom.us. – Merchako Aug 2 '18 at 17:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .