12

This is what the top of my Safari page looks like right now:

enter image description here

I think I have around 90 tabs open. That's how I work, I multitask. What made Safari stand out as a browser used to be the fact that no matter how many tabs you had open, you could still know what a page's title was. I believe page titles are super-duper important, and that getting rid of them for users with many tabs open was a mistake they made with Yosemite/new Safari.

Is there a way for me to get the page's titles back?

Like, for instance, on my screen grab, I don't need the URL to be displayed in the white bar so much as the name of the page. I've found that Safari's preference pane has a "show full website address" as if the URL was more important than a page name - something I disagree with whole-heartedly, but maybe there's another setting somewhere else to display page title instead of the URL?

  • The Show All Tabs function can be keymapped or have it's button show up on the Toolbar. It opens a view of tiles of pages with the page title showing. You could imagine the purpose is to provide the functionality you relied on prior to the Safari change in late 2012. I searched and could find no extension providing the functionality in another way. – user90735 Sep 4 '15 at 9:26
  • 2
    I don't have the programming chops to accomplish this myself, but it would definitely be possible to write a Safari extension to add an "extension bar", as Apple calls it, which simply displays the title of the current page (safari.application.activeBrowserWindow.activeTab.title)... – Timothy Mueller-Harder Jan 6 '17 at 6:44
1

Go to Safari preferences > advanced then uncheck the box that says 'Smart search Field - show full website address'

-2

Mine disappeared completely yesterday. All blank.

Go to View > Customize Toolbar and drag the default set into the toolbar. This seems to reset something and the titles reappear immediately. You can then re-customize it back to your liking.

Bizarre, but the fix works on Safari 10.0.2 (the link refers to 9.0)

Does not work on Safari 11.x (High Sierra)

  • This does not work in Safari 11.0.1 on macOS 10.13.1. – jwodder Nov 27 '17 at 21:04
  • Unfortunately, going to View and using the default set is only a temporary fix in Safari 11.0.1. New tabs open as blank. – Yuri Shukost Dec 3 '17 at 2:39
-4

In Safari's View menu choose "Show Tab Bar"

  • 1
    I don't think you read the question through. Look at the screengrab in the original question: tab bar is there – MicroMachine Jan 4 '17 at 20:55
-5

I don't know if this is possible with Safari, but with Firefox, you can:

  1. Go to about:config. (You can click through the warning about your "warranty".)

  2. Enter the option browser.tabs.drawInTitlebar in the search field on top and press return to filter.

  3. Double click the option to toggle it to false.

screenshot of about:config

  • Thanks! That's good to know for if I ever started using Firefox... – MicroMachine Apr 4 '16 at 4:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .