The Activity app on my iPhone always shows the "setup" screen: "Set up Activity on your Apple Watch". I have already set up Activity on my Apple Watch; it works fine and shows the rings filling up each day. But I cannot access historical Activity data which should be displayed in the iPhone app.

I have tried restoring the watch from a backup and setting up the watch as new. Neither has worked.

A little background: I bought my Apple Watch along with my iPhone 6s Plus. That initial pairing worked without any bugs in Activity on phone or watch. However, two weeks after purchase, my iPhone experienced some kind of catastrophic failure. I got it replaced at the Apple Store. Since pairing my watch with the replacement phone, the iPhone Activity app has never recognized that I have already set up the Watch Activity app.

up vote 1 down vote accepted

I have since solved the problem. Something was seemingly corrupted in the iPhone's Health database. Nothing could read or write data to the Health database, including step data (which should be automatically added from the Mwhatever chip) and manually entered data such as weight.

To solve the issue, I unpaired the phone and watch, then set up both the phone and watch as new. Setting up the phone from a backup did not solve the problem because the (hypothesized) corrupt database was (seemingly) included in the backup.

Since setting up the phone as new and re-pairing the watch, Health data works fine.

Only thing I have found online about this is a reset and setup as new corrects the issue. Restoring from backup will not work

  • Unfortunately, I have already tried this. It did not solve the problem. – Flavin Dec 27 '15 at 17:53

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.