2

If I search for a song and select it from the search results, it starts to play as expected. But for some reason, if I open an album, I can't select a track to play, I can only shuffle the album and skip tracks until I get the one I wanted. The tracks are greyed out.

Why can't I directly play tracks from albums? I'm currently on my free trial.

Edit: This does not happen only on explicit tracks, and I have restrictions off, so it's not that.

1

The problem is indicated by the track names being grey.

Something is preventing your device from connecting to the store.

  • Try another network connection
  • Try on cellular data
  • Try powering off phone
  • Ensure that you were allowing cellular data to playback iTunes music from the cloud
  • once you've ruled these out, consider filing a bug or feedback to Apple

You will know that you solved the problem when you see the track names in bright white just like the rest of the text on the page. Compare the shuffle text with the first track name in your screenshot for example.

enter image description here

  • Thanks for the suggestions, but I've already tried all of those. The funny thing is that shuffle works, so there is some kind of a connection. I've submitted feedback to apple about this, so hopefully it works in the next version. – onik Aug 12 '15 at 16:08
  • @onik Build 13A4325c works for me on that specific album - I'm on an iPad Air 2 however... I would expect shuffle to work since it is drawn in white - the system is actually sophisticated enough to indicate which controls will work and which controls will not work by the color of the text. I learn far, far more about how software works when it breaks. sadly for you it means you can't listen to the track you want at the same time you're learning how things work under the hood – bmike Aug 12 '15 at 16:10
  • 1
    It works on my iPad Air WiFI+Cellular and on my MacBook Air mid-2013 running 10.11, so it's either a random bug or something iPhone- or iPhone-6-plus-specific. – onik Aug 12 '15 at 16:15
0

I found the problem, I had iCloud Music Library disabled in Settings --> Music. Checking this enabled all tracks for me!

-2

I'm dealing with this myself. I selected the triple dots in the upper right and selected to make the album available offline. I'm hoping to see the songs show available when we connect to wifi

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .