1

I have Yosemite 10.10.2 on my Early 2008 24". Time Machine has been backing up to my WD external hard drives for years. I just purchased a new 2TB My Passport using USB 3.0. It's formatted in Mac OS Extended (Journaled). The device shows up on by desktop and it does store files that I drag into it. However, Time Machine does not recognize it.

Any thoughts? Is it Time Machine or the 3.0 USB?

  • If you did not format it, try using Disk Utility to format it. This sounds very much like behavior one would see if the disk is formated NTFS or ExFat: Finder will mount it, and you can save files to it, but TM won't use it as it isn't HFS+ (Mac OS Extended (Journaled). – cmason Apr 28 '15 at 20:25
  • Thanks, CMason. It came formatted as Mac OS Extended (Journaled), and then I erased it and reformatted it to same using Disk Utility, just to be sure. It's still not recognized by Time Machine. – John C. Apr 28 '15 at 22:15
3

This article is quite old, but I think is probably the reason…

The partition map scheme describes how the drive stores its volumes. Drives originally set up for use on Windows usually use the Master Boot Record (MBR) scheme, as opposed to the Apple Partition Map (APM) scheme, the default for PowerPC-based Macs, or the GUID Partition Table (GPT) scheme, the default for Intel Macs. Although OS X supports MBR, there’s a catch: Mac OS Extended volumes can be no larger than 512GB on a drive partitioned with the MBR scheme. So if you have, say, a 750GB or 1TB drive, you must repartition it to use the GPT or APM scheme before it can work with Time Machine.

Source: Macworld - Time Machine tips and troubleshooting

Apple's KB doesn't seem to quite be so explicit - OS X Yosemite: Disks you can use with Time Machine

You would need to go to Disk Utility & check the drive is formatted as not only Mac OS X Extended, but that the underlying structure is GUID [most 3rd party drives will arrive as MBR/NTFS usually for Windows]

You can only change from MBR to GUID by completely erasing the drive & starting over…

Select the drive itself [not the volume]. Bottom right it will tell you the partitions scheme.
If it is not GUID, then > Partition. Select a Partition layout [not current], then Options… & set to GUID Partition Table.

enter image description here

  • 2
    You know what the problem was? When I opened Time Machine's preferences, the dialogue box offered me no prompt to add another backup disk. I had to click, hold and drag the cursor on the list of existing disks and scroll to the bottom, where it asks, "Add another disk?". Obviously, I'm not techy. Thanks to Tetsujin and CMason for tolerating my ignorance. – John C. Apr 28 '15 at 22:42
  • Glad you got it :) – Tetsujin Apr 29 '15 at 8:40
  • @JohnC. Thank you so much for that! I would have never expected something like that. I’m more used to just mount/umount and /etc/fstab to be fair but I must have forgotten that for TM you have to add the disk. I had a problem with WD My Passport and I decided to format it all over (which normally I do for new disks that come pre-formatted) and that's after removing the bloody WD utils. I had a series of problems but finally I was able to wipe the drive; at first nothing worked not even wiping it. But then I had this issue; all I had to do was remove the old and add the new. Cheers mate! – Pryftan Jun 5 at 14:57
0

I faced a similar issue where Time Machine was not detecting my first partition on a WD 1 TB disk but showing the 2nd partition available for backup. I erased the 1st partition by using Disk Utility and reformatted it to Apple native partition type. As soon as it finished doing that, it asked me whether I want to use this as a backup drive. I selected that and now Time Machine was able to pick this up :)

  • 1
    Please add the proper volume type. There is no Apple native partition type. – klanomath Nov 15 '15 at 16:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .