2

I understand this issue arose over the past 2-3 years, but I haven't seen any solution.

A workbook created on a Windows PC using Office 365 - transferred to Mac (Yosemite installed) - opens in read-only mode in Office 365 for Mac.

The workbook doesn't have a "/" in its name. I made sure there is read/write access for the file and also the folder. It contains macros, some of which work, others will have to be redone.

After saving it with a different name, I may work as usual with it like updating, saving and closing it.

After reopening it, it's again in read-only mode.

After all this time there must be a solution for the problem.

  • How was it transferred? – user151019 Apr 1 '15 at 13:27
  • copied to external hard drive then recopied onto Mac. – John Hardy Apr 2 '15 at 1:15
  • Do a Get any info on the Folder that its in read only format ?? At the bottom do you have Read Only privileges for that folder? If you do a Get Info on that Excel sheet file, can you change it so you have Read & Write? – vembutech Apr 29 '15 at 16:47
  • I have the same problem. I found that the particular file's attributes in the properties checked to the Read-only, but it is kind of locked so cant be changed. You can see the attributes in File-Properties-General. However, I could not find any way to change this attributes. – user131984 Jun 15 '15 at 6:41
2

I had the same problem. I could see the attributes set as Read-Only under the preferences but couldn't change them. I completely closed out of excel on my mac and changed the name of the excel file. That seemed to have changed the Read-Only status of my file when I opened it next. Hope this helps.

2

You actually may have a hidden lock file in the same directory as the main file is stored (usually happens to me when I use an USB stick to copy Microsoft files from somebody else). To resolve

  • Open Terminal
  • cd to the directory containing the file
  • ls -al FIRST-CHARACTERS-OF-NAME*

If there is a small file with the same name as the file which only opens read-only but a different suffix -> rm THAT-FILE.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .