3

I'm at my wits end with this issue. Hours of searching various forums have produced glimmers of hope, but nothing works.

First - mea culpa - I have only myself to blame. Short Version: I wiped my (time machine) external backup drive due to problems it was having. Before I could create a new TM backup, I left for a couple of days, came back and my startup disk was full and my Mini (mid-2011, Running Sierra) wouldn't boot. So now I have no backup to restore from.

Tried recovery mode, disk won't mount. Tried Target mode - no way no how. I've read where some people went into Single User mode and used the command line to delete some files they don't need. I've gotten as far as the command line. tried all the fsck stuff - nothing.
Tried /sbin/mount -uw / (as per this thread http://boards.straightdope.com/sdmb/showthread.php?t=554227) but I'm getting a long error message that ends in: mount_hfs: error on mount (): error = -1 mount_hfs: Invalid argument.

I've tried various rm commands, but keep getting various slaps on the wrist that end in "Read-only file system"

For obvious reasons, I'd like to try to clear enough of the clutter on this drive in hopes of rebooting and then wiping out all the clutter I should have gotten rid of a while ago before going nuclear on it and risking losing everything. I feel like I'm so close, but can't get past this pesky read-only issue. Any help would be greatly appreciated. Please note I'm not a power user-and had never typed anything into a terminal command line before I ran into this problem and started searching - i.e. I'm competent enough to follow directions very well, but only if they're dumbed-down a bit. (After all - I was dumb enough to let this happen in the first place!)

  • Do you have a thumb drive to install macOS Sierra to? (16 GB)... – klanomath Dec 19 '17 at 5:27
  • You might try removing the disk and using an enclosure or USB reader to mount the disk on a different Mac. You can try using disk utility to clone the disk to another and/or deleting some garbage so there is enough free space for it to boot. In the end, it's probably easier to salvage what stuff you know you need, nuke the disk, and make a clean installation. – www139 Dec 28 '18 at 21:31
1

The error your getting when typing in the command means that the command you typed in has invalid arguments. That means that you didn't type the command correctly.

The reason it's not letting you modify the hard drive is because the drive is only mounted in read only mode.

Mount hard drive for read and write in single user mode

/sbin/fsck -fy 

Then run:

/sbin/mount -uw

If it says something like invalid command try the commands without "/sbin/" at the beginning.

After your able to mount the disk erasing the files the other website recommended.

Also you mentioned you couldn't boot into recovery mode, but have you tried to boot into Internet Recovery Mode?

How to boot into Internet Recovery Mode

  1. Hold Option-Command-R or Shift-Option-Command-R on startup until you see a spinning globe
  2. Connect the device to Internet if prompted to do so.

Hope this helps and good luck on recovery your data

  • "If it says something like invalid command try the commands without "/sbin/" at the beginning." Why should an expanded path work better than the full path? & mount point is missing! – klanomath Dec 19 '17 at 6:12
  • When writing the post I didn’t have access to a laptop or computer to test it on, and I found both answers online and I forgot which one I’ve used in the past @klanomath – Matthew N Dec 19 '17 at 13:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .