On OS X Yosemite, I can't rearrange my dock icons. I click one, and drag, but it just stays in place and stops highlighting.

Here's a demonstration

enter image description here

This has been so ever since I upgraded to Yosemite

I've tried killing it with

killall Dock

To no avail. It just stays stuck.

After restart, I can drag once or twice but I'm not sure what event causes it to stop. If I wait too long after reboot, that privilege is taken away from me.

Any idea what can be done?


11 Answers 11


So turns out, this problem extended to other parts in the system, namely: Xcode.
After some back-and-forth communication with Apple's support case team, the crash problem in Xcode turned out to be ibtoold and pboard processes are malfunctioning. They said it's a clipboard set of processes, and if I have any clipboard-relevant apps - they might be clashing with them.

So the only possible culprit on my system was CopyClip.

To make sure that was indeed the problem, I quit CopyClip, and restarted the processes, then restarted Xcode:

killall ibtoold pboard

And it worked. I made sure that was indeed the problem by starting CopyClip again, then running the same command again - and the problem returned. I then fixed it once more.

I figured the problem might be the same for the Dock, so I killed it:

killall Dock

And voila, it was functioning again!

TL;DR: Applications that provide special handling for the clipboard, such as CopyClip or PushBullet's "Universal Copy and Paste" collide with processes necessary for Xcode and Dock to function correctly. My problem was resolved by disabling or getting rid of that app and restarting.

  • Thanks a lot for your solution, it worked for me too, I don't have CopyClip though. But killall ibtoold pboard has worked for me as well.
    – haynar
    Apr 29, 2015 at 21:51
  • I also had this problem with Sierra and your solution fixed it for me. I did not have any clipboard app, though. No running ibtoold process either. However a killall pboard followed by a killall Dock did the trick.
    – emx
    Jan 25, 2017 at 13:00
  • Did it fix it temporarily or permanently? My fix involved using killall to reset the processes, but actually removing the offending process was the fix itself. If it worked for you permanently - you had a softer issue than I had, but I'm glad it worked for you :)
    – casraf
    Jan 25, 2017 at 15:02
  • It worked, finally! Thanks for this answer, there are a lot of duplicated answers here saying to delete my dock plist files, which never solved anything for me. Jul 31, 2017 at 22:45

I was experiencing the same frustration with El Capitan (10.11.1), but discovered that the solution (in my case) was simpler than inserting code in Terminal or Xcode.

I found that if I delayed beyond the initial click I was presented with the drop down menu and was unable to drag. But, if I clicked and tried to move immediately the menu did not appear and I could drag the icon. If I kept the icon too high in the Dock the other icons would not open a space, however if I held the icon lower in the Dock they would separate, and I was able to drag and rearrange.

I hope this is helpful.

  • 6
    The key is the position of the cursor. That was key for me. To reiterate: place the cursor near the bottom of the icon when you click and drag and it all works well to move it.
    – user175149
    Mar 13, 2016 at 6:20
  • 3
    The key for me was the fast speed that you click and drag, needs to be very fast Oct 22, 2016 at 10:17
  • just had that issue too, clicking and moving fast did indeed still help in Catalina
    – TheEye
    Feb 5, 2021 at 9:18

try this way,delete the file ~/library/preferences/com.apple.dock.plist and restart. your dock, spaces and expose will be reset to the defaults. try rearranging the dock icons again.May be it will fix errors.

  • 1
    This one worked for me as well. I ran 'killall Dock' afterwards
    – fret
    May 19, 2018 at 11:29

I found that when I turn off (uncheck) "Automatically hide and show the dock" in the Dock System Preference I am able to rearrange items in the dock. But when that box is checked I can't. OS X 10.10.3 on a MacBook Pro.

  • I never used to have that checkbox on, so I'm not sure this applied to everyone
    – casraf
    May 12, 2015 at 16:24
  • My fix is similar. After deselecting "Show recent applications in Dock" in the same menu, the rearrangement comes back. May 28, 2019 at 23:04
  • I reinstalled macOS yesterday and encountered this issue again. Found my old solution 2 years ago. Deselecting "Show recent applications in Dock" works today! May 13, 2021 at 20:39

I had the same problem happen to me as well. In my case I use an app called "TinkerTool" to help me modify some system settings.

The solution has been posted here as well: https://apple.stackexchange.com/a/168545/110691

Even if you do not use TinkerTool, you could try using it to solve your problem.


I just noticed this problem and found (at least for me) a very simple solution). Certain items in the dock are not assigned to any of my desktops (right-click/"Options") Changing the item to apply to my desktops fixed the problem. I am using Yosemite but I can't be sure whether this happened prior to the upgrade.


I find that by clicking just a fraction below the icon, it will allow me to move it. Don't know yet if this is permanent.


The answer to the problem seems to be is to go into the Applications folder and drag the relevant app to the position on the dock where you wish it to be.


Click and drag quickly (very quickly!) before the menu pops up worked for me, but it's more of a workaround than a solution. It used to work fine but haven't tried lately and probably not since the last upgrade.(Yosemite on iMac)


System Preferences -> Trackpad. Enable 3 finger drag-drop. Solved it for me.


You have to move the item before the menu pops up. So click and immediately move the icon.

  • I have no problem moving icons in the dock after their name pop shows. I don't think this the solution.
    – Ian C.
    Aug 28, 2015 at 6:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .