1

The other day MultiMarkdown Composer started crashing on launch, and I can’t get it to stop. (The app appears in the dock and then immediately crashes again.)

I have tried:

  1. Deleting the app and reinstalling it

  2. Deleted files and folders:

    • ~/Library/Preferences/com.multimarkdown.composer.mac.*
    • ~/Library/Application Support/MultiMarkdown Composer/
    • ~/Library/Caches/com.multimarkdown.composer.mac/
  3. open -F -a 'MultiMarkdown Composer'

    • -F Opens the application "fresh," that is, without restoring windows. Saved persistent state is lost, except for Untitled documents.

Trying to app in a separate user account works, so it has to be something related to my user account, but I can’t figure out what.

The developer looked at the crash logs and they indicate that it’s trying to read a file when it starts up, but the logs don’t show which file.

So I am trying to find out what files/folders are being accessed when the app is being launched, thinking that might lead to a solution.

What tools are available to do that, and how should I use them?

I tried sudo fs_usage -w -f pathname -f filesys but that didn’t appear to show anything useful.

Any other ideas?

(This is on Mac OS X 10.8.5)

2

Try using opensnoop:

sudo opensnoop

(You can also use -n to specify the process name, but it doesn't work with arguments that contain spaces by default. To fix it, replace "'$pname'" with "'"$pname"'" in /usr/bin/opensnoop.)

You could also try to delete files in ~/Library/Containers/ or ~/Library/Saved Application State/.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .