0

Problem description: After having made the mistake of running a Unix command that altered more files than I intended and possibly damaged the file system, I decided to restore to a previous state with Time Machine.

Evidently, something was corrupted with the latest backup, since the system said it couldn’t restore every time I tried to use it. But I succeeded with the second newest backup.

Since the restoration, the Spotlight icon has disappeared from the corner of the menu bar, and cannot be activated with keyboard shortcuts. The same problem exists whether I start in safe mode or from a fresh account.

The .app file still exists in CoreServices, and indexing appears to continue, as I am able to conduct searches through finder windows. I have tried emptying all the caches, restarting SystemUIServer and the menubar itself.

I have never, to my knowledge, instructed an application or the computer to hide Spotlight from the menubar. And though I doubt this is the issue, it is interesting that when I select in Onyx the option to hide it, and then deselect it, there’s a short little flash in the corner where the icon should be as if it tries to start for a moment but for whatever reason crashes.

It appears from the console that every second it is trying to load when this happens:

file:///Users/SRF/Library/Logs/DiagnosticReports/Spotlight_2015-02-11-163022_MacBookPro.crash

2/11/15 4:30:46.173 PM com.apple.xpc.launchd[1] (com.apple.Spotlight[1951]) Service exited due to signal: Trace/BPT trap: 5

2/11/15 4:30:46.173 PM com.apple.xpc.launchd[1] (com.apple.Spotlight) Service only ran for 0 seconds. Pushing respawn out by 1 seconds.

2/11/15 4:30:46.174 PM ReportCrash[1919] Saved crash report for Spotlight[1951] version ??? to /Users/SRF/Library/Logs/DiagnosticReports/Spotlight_2015-02-11-163046_MacBookPro.crash

2/11/15 4:30:46.175 PM ReportCrash[1919] Removing excessive log:

And then from the CrashReport:

Application Specific Information: dyld: launch, loading dependent libraries

Dyld Error Message: Library not loaded: /System/Library/PrivateFrameworks/ParsecUI.framework/Versions/A/ParsecUI Referenced from: /System/Library/CoreServices/Spotlight.app/Contents/MacOS/Spotlight Reason: image not found

Any comments, advice or pointers would be greatly appreciated!

EtreCheck version: 2.1.8 (121) Report generated February 11, 2015 at 4:54:44 PM EST Download EtreCheck from http://etresoft.com/etrecheck

Hardware Information: ℹ️ MacBook Pro (Retina, 15-inch, Late 2013) (Technical Specifications) MacBook Pro - model: MacBookPro11,3 1 2.6 GHz Intel Core i7 CPU: 4-core 16 GB RAM Not upgradeable BANK 0/DIMM0 8 GB DDR3 1600 MHz ok BANK 1/DIMM0 8 GB DDR3 1600 MHz ok Bluetooth: Good - Handoff/Airdrop2 supported Wireless: en0: 802.11 a/b/g/n/ac Battery Health: Normal - Cycle count 111

Video Information: ℹ️ Intel Iris Pro NVIDIA GeForce GT 750M - VRAM: 2048 MB Color LCD spdisplays_2880x1800Retina

System Software: ℹ️ OS X 10.10.2 (14C109) - Time since boot: 0:36:32

Disk Information: ℹ️ APPLE SSD SM1024F disk0 : (1 TB) EFI (disk0s1) : 210 MB Recovery HD (disk0s3) [Recovery]: 650 MB Macintosh HD (disk1) / : 999.33 GB (497.93 GB free) Core Storage: disk0s2 999.70 GB Online

USB Information: ℹ️ Apple Internal Memory Card Reader Apple Inc. BRCM20702 Hub Apple Inc. Bluetooth USB Host Controller Apple Inc. Apple Internal Keyboard / Trackpad Kingston DT 101 G2 15.51 GB DiskWarrior Recovery (disk2s1) /Volumes/DiskWarrior Recovery : 15.51 GB (14.24 GB free)

Thunderbolt Information: ℹ️ Apple Inc. thunderbolt_bus

Configuration files: ℹ️ /etc/sysctl.conf - Exists

Gatekeeper: ℹ️ Anywhere

Kernel Extensions: ℹ️ /Applications/DiskWarrior.app [not loaded] com.alsoft.Preview (5 - SDK 10.5) [Click for support]

    /Applications/VMware Fusion.app
[not loaded]    com.vmware.kext.vmci (90.6.3) [Click for support]
[not loaded]    com.vmware.kext.vmioplug.14.1.3 (14.1.3) [Click for support]
[not loaded]    com.vmware.kext.vmnet (0231.47.74) [Click for support]
[not loaded]    com.vmware.kext.vmx86 (0231.47.74) [Click for support]
[not loaded]    com.vmware.kext.vsockets (90.6.0) [Click for support]

    /Library/Application Support/VirtualBox
[loaded]    org.virtualbox.kext.VBoxDrv (4.3.20) [Click for support]
[loaded]    org.virtualbox.kext.VBoxNetAdp (4.3.20) [Click for support]
[loaded]    org.virtualbox.kext.VBoxNetFlt (4.3.20) [Click for support]
[loaded]    org.virtualbox.kext.VBoxUSB (4.3.20) [Click for support]

    /Library/Extensions
[not loaded]    com.blackmagic-design.desktopvideo.iokit.driver (10.3.4 - SDK 10.9) [Click for support]
[not loaded]    com.blackmagic-design.desktopvideo.iokit.framebufferdriver (10.3.4 - SDK 10.9) [Click for support]
[not loaded]    com.blackmagic-design.desktopvideo.multibridge.iokit.driver (10.3.4 - SDK 10.9) [Click for support]
[not loaded]    com.blackmagic-design.driver.BlackmagicIO (10.3.4 - SDK 10.9) [Click for support]
[not loaded]    com.blackmagic-design.driver.BlackmagicUsbIO (10.3.4 - SDK 10.9) [Click for support]

    /Library/Extensions/DeckLink_Driver.kext/Contents/PlugIns
[not loaded]    com.blackmagic-design.desktopvideo.firmware (10.3.4 - SDK 10.9) [Click for support]

    /System/Library/Extensions
[not loaded]    com.makemkv.kext.daspi (1) [Click for support]
[loaded]    com.nvidia.CUDA (1.1.0) [Click for support]
[loaded]    com.plantronics.driver.PlantronicsDriverShield (4.3 - SDK 10.8) [Click for support]

Problem System Launch Agents: ℹ️ [failed] com.apple.security.keychain-circle-notification.plist [Click for details] [failed] com.apple.Spotlight.plist [Click for details]

Launch Agents: ℹ️ [not loaded] com.adobe.AAM.Updater-1.0.plist [Click for support] [loaded] com.adobe.AdobeCreativeCloud.plist [Click for support] [running] com.bjango.istatmenusagent.plist [Click for support] [running] com.bjango.istatmenusnotifications.plist [Click for support] [running] com.blackmagic-design.DesktopVideoFirmwareUpdater.plist [Click for support] [running] com.brother.LOGINserver.plist [Click for support] [not loaded] com.maintain.LogOut.plist [Click for support] [not loaded] com.maintain.PurgeInactiveMemory.plist [Click for support] [not loaded] com.maintain.Restart.plist [Click for support] [not loaded] com.maintain.ShutDown.plist [Click for support] [not loaded] com.maintain.Sleep.plist [Click for support] [running] com.maintain.SystemEvents.plist [Click for support] [loaded] com.nvidia.CUDASoftwareUpdate.plist [Click for support] [unknown] com.oracle.java.Java-Updater.plist [Click for support] [not loaded] com.plantronics.Spokes.plist [Click for support] [not loaded] org.gpgtools.gpgmail.enable-bundles.plist [Click for support] [loaded] org.macosforge.xquartz.startx.plist [Click for support]

Launch Daemons: ℹ️ [not loaded] com.adobe.adobeupdatedaemon.plist [Click for support] [loaded] com.adobe.fpsaud.plist [Click for support] [running] com.backblaze.bzserv.plist [Click for support] [running] com.bjango.istatmenusdaemon.plist [Click for support] [loaded] com.blackmagic-design.desktopvideo.XPCService.plist [Click for support] [running] com.blackmagic-design.DesktopVideoHelper.plist [Click for support] [running] com.blackmagic-design.streaming.BMDStreamingServer.plist [Click for support] [loaded] com.bresink.system.privilegedhelper-tts.plist [Click for support] [loaded] com.creativebe.MainMenuHelper.plist [Click for support] [not loaded] com.edb.launchd.postgresql-8.4.plist [Click for support] [not loaded] com.informer.mac.daemon.plist [Click for support] [loaded] com.macromates.auth_server.plist [Click for support] [not loaded] com.maintain.CocktailScheduler.plist [Click for support] [not loaded] com.maintain.HideSpotlightMenuBarIcon.plist [Click for support] [loaded] com.microsoft.office.licensing.helper.plist [Click for support] [loaded] com.nvidia.cuda.launcher.plist [Click for support] [unknown] com.oracle.java.Helper-Tool.plist [Click for support] [loaded] com.oracle.java.JavaUpdateHelper.plist [Click for support] [loaded] com.soma-zone.LaunchControl.Helper.plist [Click for support] [loaded] com.sonos.smbbump.plist [Click for support] [loaded] org.macosforge.xquartz.privileged_startx.plist [Click for support] [not loaded] org.virtualbox.startup.plist [Click for support]

User Launch Agents: ℹ️ [not loaded] com.adobe.AAM.Updater-1.0.plist [Click for support] [loaded] com.adobe.ARM.[...].plist [Click for support] [running] com.backblaze.bzbmenu.plist [Click for support] [not loaded] com.ctmdev.foxtrot.prostarter.plist [Click for support] [loaded] com.google.keystone.agent.plist [Click for support] [not loaded] com.informer.mac.client.plist [Click for support] [loaded] com.leadertech.PowerRegister.SEA1.5dbf409444be57eee48085fc658738f0.plist [Click for support] [running] com.pia.pia_manager.plist [Click for support] [not loaded] org.virtualbox.vboxwebsrv.plist [Click for support] [not loaded] SOS.OnlineBackup.LaunchAgent.plist [Click for support]

User Login Items: ℹ️ Citations Application (/Applications/Papers.app/Contents/SharedSupport/Citations.app) iTunesHelper Application (/Applications/iTunes.app/Contents/MacOS/iTunesHelper.app) Dropbox Application Hidden (/Applications/Dropbox.app) Alfred 2 Application (/Applications/Alfred 2.app) TextExpander Application (/Users/[redacted]/.Trash/TextExpander.app) HazelHelper Application (/Users/[redacted]/Library/PreferencePanes/Hazel.prefPane/Contents/MacOS/HazelHelper.app) DiskWarriorDaemonStarter Application (/Applications/DiskWarrior.app/Contents/Helpers/DiskWarriorStarter.app)

Internet Plug-ins: ℹ️ AdobeAAMDetect: Version: AdobeAAMDetect 2.0.0.0 - SDK 10.7 [Click for support] FlashPlayer-10.6: Version: 16.0.0.305 - SDK 10.6 [Click for support] QuickTime Plugin: Version: 7.7.3 Flash Player: Version: 16.0.0.305 - SDK 10.6 [Click for support] Default Browser: Version: 600 - SDK 10.10 SharePointBrowserPlugin: Version: 14.4.7 - SDK 10.6 [Click for support] Mathematica: Version: 9.0.1.4092152 [Click for support] JavaAppletPlugin: Version: Unknown Check version

User internet Plug-ins: ℹ️ Google Earth Web Plug-in: Version: 7.1 [Click for support]

Safari Extensions: ℹ️ JavaScript Blocker Open in Papers Blur (Formerly DoNotTrackMe) Disconnect Zotero Connector DuckDuckGo 1Password Clip to DEVONthink Adblock Plus

3rd Party Preference Panes: ℹ️ Backblaze Backup [Click for support] Blackmagic Desktop Video [Click for support] CleanApp Logging Service [Click for support] CUDA Preferences [Click for support] Default Folder X [Click for support] Flash Player [Click for support] FUSE for OS X (OSXFUSE) [Click for support] Hazel [Click for support] Perian [Click for support]

Time Machine: ℹ️ Mobile backups: OFF Auto backup: NO - Auto backup turned off Volumes being backed up: Destinations: Seagate [Local] Total size: 999.86 GB Total number of backups: 6 Oldest backup: 2015-02-02 07:49:49 +0000 Last backup: 2015-02-07 07:22:10 +0000 Size of backup disk: Excellent Backup size 999.86 GB > (Disk size 0 B X 3)

Top Processes by CPU: ℹ️ 51% Console 7% WindowServer 3% mds 1% pia_tray 1% hidd

Top Processes by Memory: ℹ️ 653 MB Finder 618 MB Safari 515 MB Console 210 MB com.apple.WebKit.WebContent 172 MB WindowServer

Virtual Memory Information: ℹ️ 10.18 GB Free RAM 4.81 GB Active RAM 667 MB Inactive RAM 1.51 GB Wired RAM 1.87 GB Page-ins 0 B Page-outs

Diagnostics Information: ℹ️ Feb 11, 2015, 04:54:36 PM /Users/[redacted]/Library/Logs/DiagnosticReports/Spotlight_2015-02-11-165436_[redacted].crash Feb 11, 2015, 04:54:34 PM /Users/[redacted]/Library/Logs/DiagnosticReports/Spotlight_2015-02-11-165434_[redacted].crash Feb 11, 2015, 04:54:33 PM /Users/[redacted]/Library/Logs/DiagnosticReports/Spotlight_2015-02-11-165433_[redacted].crash Feb 11, 2015, 04:54:31 PM /Users/[redacted]/Library/Logs/DiagnosticReports/Spotlight_2015-02-11-165431_[redacted].crash Feb 11, 2015, 04:54:28 PM /Users/[redacted]/Library/Logs/DiagnosticReports/Spotlight_2015-02-11-165428_[redacted].crash Feb 11, 2015, 04:54:26 PM /Users/[redacted]/Library/Logs/DiagnosticReports/Spotlight_2015-02-11-165426_[redacted].crash Feb 11, 2015, 04:54:23 PM /Users/[redacted]/Library/Logs/DiagnosticReports/Spotlight_2015-02-11-165423_[redacted].crash Feb 11, 2015, 04:54:21 PM /Users/[redacted]/Library/Logs/DiagnosticReports/Spotlight_2015-02-11-165421_[redacted].crash Feb 11, 2015, 04:54:18 PM /Users/[redacted]/Library/Logs/DiagnosticReports/Spotlight_2015-02-11-165418_[redacted].crash Feb 11, 2015, 04:54:15 PM /Users/[redacted]/Library/Logs/DiagnosticReports/Spotlight_2015-02-11-165415_[redacted].crash Feb 11, 2015, 08:16:18 AM /Library/Logs/DiagnosticReports/DiskWarrior_2015-02-11-081618_[redacted].cpu_resource.diag [Click for details] Feb 11, 2015, 07:31:16 AM /Library/Logs/DiagnosticReports/Spotlight_2015-02-11-073116_[redacted].crash Feb 11, 2015, 07:30:20 AM /Library/Logs/DiagnosticReports/Spotlight_2015-02-11-073020_[redacted].crash Feb 11, 2015, 07:24:14 AM /Library/Logs/DiagnosticReports/postgres_2015-02-11-072414_[redacted].crash Feb 11, 2015, 07:23:43 AM /Library/Logs/DiagnosticReports/postgres_2015-02-11-072343_[redacted].crash Feb 11, 2015, 07:23:32 AM /Library/Logs/DiagnosticReports/postgres_2015-02-11-072332_[redacted].crash Feb 11, 2015, 07:23:12 AM /Library/Logs/DiagnosticReports/postgres_2015-02-11-072312_[redacted].crash Feb 11, 2015, 07:23:02 AM /Library/Logs/DiagnosticReports/postgres_2015-02-11-072302_[redacted].crash Feb 11, 2015, 07:22:31 AM /Library/Logs/DiagnosticReports/postgres_2015-02-11-072231_[redacted].crash Feb 11, 2015, 07:22:20 AM /Library/Logs/DiagnosticReports/postgres_2015-02-11-072220_[redacted].crash Feb 11, 2015, 07:22:00 AM /Library/Logs/DiagnosticReports/postgres_2015-02-11-072200_[redacted].crash Feb 11, 2015, 07:21:39 AM /Library/Logs/DiagnosticReports/postgres_2015-02-11-072139_[redacted].crash Feb 11, 2015, 07:21:08 AM /Library/Logs/DiagnosticReports/postgres_2015-02-11-072108_[redacted].crash Feb 11, 2015, 07:20:58 AM /Library/Logs/DiagnosticReports/postgres_2015-02-11-072058_[redacted].crash Feb 11, 2015, 05:56:00 AM /Library/Logs/DiagnosticReports/Spotlight_2015-02-11-055600_[redacted].crash Feb 11, 2015, 04:54:32 PM /Users/[redacted]/Library/Logs/DiagnosticReports/Spotlight_2015-02-11-165432_[redacted].crash Feb 11, 2015, 04:54:30 PM /Users/[redacted]/Library/Logs/DiagnosticReports/Spotlight_2015-02-11-165430_[redacted].crash Feb 11, 2015, 04:54:29 PM /Users/[redacted]/Library/Logs/DiagnosticReports/Spotlight_2015-02-11-165429_[redacted].crash Feb 11, 2015, 04:54:24 PM /Users/[redacted]/Library/Logs/DiagnosticReports/Spotlight_2015-02-11-165424_[redacted].crash Feb 11, 2015, 04:54:22 PM /Users/[redacted]/Library/Logs/DiagnosticReports/Spotlight_2015-02-11-165422_[redacted].crash Feb 11, 2015, 04:54:19 PM /Users/[redacted]/Library/Logs/DiagnosticReports/Spotlight_2015-02-11-165419_[redacted].crash Feb 11, 2015, 04:54:16 PM /Users/[redacted]/Library/Logs/DiagnosticReports/Spotlight_2015-02-11-165416_[redacted].crash Feb 11, 2015, 04:54:14 PM /Users/[redacted]/Library/Logs/DiagnosticReports/Spotlight_2015-02-11-165414_[redacted].crash Feb 11, 2015, 04:31:20 PM /Users/[redacted]/Library/Logs/DiagnosticReports/garcon_2015-02-11-163120_[redacted].crash Feb 11, 2015, 04:17:59 PM Self test - passed Feb 11, 2015, 07:30:44 AM /Library/Logs/DiagnosticReports/Spotlight_2015-02-11-073044_[redacted].crash Feb 11, 2015, 07:30:44 AM /Users/[redacted]/Library/Logs/DiagnosticReports/2015-02-11-073044[redacted].crash Feb 11, 2015, 07:28:25 AM /Library/Logs/DiagnosticReports/Spotlight_2015-02-11-072825_[redacted].crash Feb 11, 2015, 07:24:03 AM /Library/Logs/DiagnosticReports/postgres_2015-02-11-072403_[redacted].crash Feb 11, 2015, 07:23:53 AM /Library/Logs/DiagnosticReports/postgres_2015-02-11-072353_[redacted].crash Feb 11, 2015, 07:23:22 AM /Library/Logs/DiagnosticReports/postgres_2015-02-11-072322_[redacted].crash Feb 11, 2015, 07:22:41 AM /Library/Logs/DiagnosticReports/postgres_2015-02-11-072241_[redacted].crash Feb 11, 2015, 07:22:10 AM /Library/Logs/DiagnosticReports/postgres_2015-02-11-072210_[redacted].crash Feb 11, 2015, 07:21:49 AM /Library/Logs/DiagnosticReports/postgres_2015-02-11-072149_[redacted].crash Feb 11, 2015, 07:21:29 AM /Library/Logs/DiagnosticReports/postgres_2015-02-11-072129_[redacted].crash Feb 11, 2015, 07:21:18 AM /Library/Logs/DiagnosticReports/postgres_2015-02-11-072118_[redacted].crash Feb 11, 2015, 05:37:39 AM /Users/[redacted]/Library/Logs/DiagnosticReports/CleanApp_2015-02-11-053739_[redacted].crash Feb 11, 2015, 04:54:25 PM /Users/[redacted]/Library/Logs/DiagnosticReports/Spotlight_2015-02-11-165425_[redacted].crash Feb 11, 2015, 04:54:17 PM /Users/[redacted]/Library/Logs/DiagnosticReports/Spotlight_2015-02-11-165417_[redacted].crash Feb 11, 2015, 07:22:51 AM /Library/Logs/DiagnosticReports/postgres_2015-02-11-072251_[redacted].crash

1

At this point I see two options for a potential fix. If in a new admin user spotlight is functional, then I would remove .plist files from your user library preferences. If it is not functional, then you will need to reinstall Yosemite from the recovery partition due to the application being corrupt.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .