Skip to main content

Questions tagged [rosetta-2]

Rosetta 2 refers to the Rosetta Translation Environment run in Mac OS X for Apple silicon that allows Apple silicon Macs to run code compiled for x86_64 (Intel) Macs.

Filter by
Sorted by
Tagged with
0 votes
0 answers
30 views

What could cause a Docker container using Rosetta to get stuck at 100% CPU with huge `sendmsg` call traces?

I am running a linux/amd64 container in Docker on an arm64 macbook running macos 14.1. Within that container I am doing a yarn build (using node.js and other tools) on a codebase I am developing which ...
Sparr's user avatar
  • 1,119
2 votes
0 answers
188 views

Force SDKMAN! to install for Intel versions on ARM (Apple Silicon) Macs?

SDKMAN! does a great job of identifying that the running Mac has an Apple Silicon (ARM) chip and filtering its offerings accordingly. For example, sdk list java shows only JDK product for the M1/M2/M3 ...
Basil Bourque's user avatar
2 votes
2 answers
8k views

Docker Desktop app for Apple Silicon requires Rosetta 2. Why?

After installing Docker Desktop app version 4.25 on my MacBook Pro running macOS Sonoma, I was prompted to install Rosetta 2. I verified that I had indeed downloaded the version of Docker Desktop for ...
Basil Bourque's user avatar
2 votes
0 answers
244 views

Configure poetry to create x86 environment

TLDR How can I configure poetry to use/create an x86 environment? Details My python project has a dependency that is not available for apple silicon (I use a Macbook Pro M2). A plain pip install will ...
ElRudi's user avatar
  • 193
1 vote
0 answers
294 views

Trying to assemble and run x86_64 assembly on M1

For a university course i need to use x86_64 assembly (AT&T syntax) and I was wondering if there is a way to run this through rosetta 2. So far I've set the OG terminal to run through Rosetta 2, ...
Max M's user avatar
  • 11
1 vote
1 answer
3k views

How to install Rosetta 2 manually? [duplicate]

Rosetta installation dialog is shown when install application which needs Rosetta to run. But how can I install Rosetta without such an application? Rosetta is not available in App Store.
Michal Bernhard's user avatar
0 votes
0 answers
50 views

Why does macOS say Carrot Weather needs Rosetta when opening WhatsApp?

I'm setting up a new MBP 14" M2, freshly updated to macOS 13.2. I've installed a bunch of apps, including both Carrot Weather and WhatsApp, both from the App Store. When I startup WhatsApp is ...
Alex's user avatar
  • 9,640
0 votes
2 answers
2k views

Drawbacks to apply Rosetta to all apps

On Macbooks with M1 chip (arm64) , Rosetta2 is a translator from Intel x86 to M1 silicon chip. In order to install Rosetta on your Macbook, enter in the Terminal softwareupdate --install-rosetta When ...
Raymond Chenon's user avatar
5 votes
2 answers
4k views

Can't duplicate apps from Apple (like Terminal.App) in macOS 13

I am using conda a lot and for some packages and environments I need x86_64 architecture. I did this by duplicating my Terminal.app and starting one duplicate with Rosetta (as described here: https://...
gernophil's user avatar
  • 349
12 votes
1 answer
15k views

What is `oahd-helper` and why is it eating my CPU?

I noticed today that when changing SIP mode (either enabling or disabling), upon reboot my macOS Monterey CPU usage is heavily consumed by a series of oahd and oahd-helper processes. Researching ...
luckman212's user avatar
  • 3,243
0 votes
0 answers
2k views

Issue with Rosetta 2 installation

I tried to install Rosetta 2 I got the following message: softwareupdate --install-rosetta --agree-to-license By using the agreetolicense option, you are agreeing that you have run this tool with the ...
numq's user avatar
  • 1
0 votes
0 answers
189 views

Disable automatic Rosetta translation for `.pkg` applications

When I'm installing Microsoft Office for Mac (universal), the installer hangs at the end. Checking the logs, I see that it's because oahd is translating the Intel part. I do not use any plugins, so I ...
Joy Jin's user avatar
  • 2,833
1 vote
1 answer
14k views

How can I run a script in Rosetta from terminal on M1 Mac? [duplicate]

How can I run a shell/bash/zsh script in Rosetta from Terminal without having the Terminal being opened in Rosetta?
hfossli's user avatar
  • 294
1 vote
0 answers
2k views

How to determine the architecture of running process from the command line

I would like to get the architecture of running processes from the command line (similarly to the "Kind" column in the Activity Monitor).
Matteo's user avatar
  • 8,975
33 votes
3 answers
65k views

What is the 'CarbonComponentScannerXPC' process? Do I have a way to remove it?

I am using a m1 MacBook Pro and do not want any intel applications. Therefore all apps I install are either universal or plain arm64. But rosetta2 is still activated because ms office 2019 which ...
cdowen's user avatar
  • 479
8 votes
1 answer
8k views

Apple Silicon: /usr/bin/mandoc: Bad CPU type in executable

I recently upgraded from an Intel Mac to an Apple Silicon Mac. When running man ssh then hitting Q in Terminal it throws the following error: sh: /usr/bin/mandoc: Bad CPU type in executable My guess ...
Charlie Fish's user avatar
2 votes
2 answers
15k views

Playing League of Legends on an external monitor with Apple silicon (display glitchiness)

I just bought myself a 14" MacBook Pro (M1 Pro), which I use as my personal computer, including for casually playing League of Legends (a popular MOBA game). I am connected to an external display ...
Karim Nassar's user avatar
53 votes
4 answers
83k views

How to tell if M1 Mac has Rosetta installed?

I am trying to run only native software. So I would like to be able to monitor whether Rosetta 2 is available or not. I am not asking if Rosetta 2 is running. I am asking if Rosetta 2 is present, is ...
Basil Bourque's user avatar
7 votes
1 answer
2k views

How can I limit the disk usage of the Rosetta 2 oah cache?

On macOS 11, Rosetta2 apparently caches translated programs and shared libraries under /var/db/oah. On an M1-based CI instance where we are testing per-commit-novel x86_64 binaries under Rosetta2, ...
acm's user avatar
  • 297
11 votes
1 answer
17k views

Conditionally run program using Rosetta 2 on M1 Mac

Is it possible to start a program using the command line in a way that has it run by Rosetta 2, without having the application setting that forces the program to always be running under Rosetta 2. e.g....
MichaelK's user avatar
  • 111
14 votes
2 answers
20k views

How am I running x86_64 programs without arch on Apple Silicon?

After getting an M1 MacBook Air, I wanted to install some command-line packages. Following this blog post, I duplicated Terminal.app and set it to run with Rosetta. Using this x86_64 terminal, I ...
seasonedfish's user avatar
3 votes
0 answers
664 views

Copy of Terminal app is removed after each restart

I'm using a M1 Mac Mini and have created a duplicate of the Terminal app called "Rosetta Terminal" that runs Rosetta. Each time I restart/update my computer this duplicate is removed from ...
Johan Nordberg's user avatar
18 votes
5 answers
8k views

Tell if running process is running under Rosetta or is M1-native by Command Line

If you have an M1-based Macbook you can tell if a process running on the machine is Apple/M1 or Intel/Rosetta in Activity Monitor, but is there a way to get this information on the command line? I'd ...
Adam Parkin's user avatar
  • 1,521
3 votes
1 answer
666 views

Does MacOS on M1 prioritise arm binaries later on path?

I'm trying to nix my new M1 Mac with home-manager and I'm thinking I might wanna skip xcode devtools altogether. I've installed nix and home-manager and built a generation with git, but: viktor@...
Viktor Hedefalk's user avatar
17 votes
3 answers
25k views

Run everything in Rosetta 2 on Silicon Mac

I've recently started using a Silicon MacBook Pro 13 (i.e. one with non-Intel processor). I have found installing some software difficult, for example installing Python through Homebrew and installing ...
user505117's user avatar
3 votes
1 answer
34k views

Open with Rosetta not available

I've just downloaded Visual Studio Code ( 1.51.1 ) on an Apple Silicon MBP. I downloaded the Intel version (the ARM version is still in dev I think) assuming that I would have to right click and ...
Ash Hogarth's user avatar
14 votes
2 answers
10k views

How does Rosetta 2 work?

I'd love to understand more about how Rosetta 2 works. The Apple Developer article is brief. Has anyone done a deep analysis on how Rosetta 2 works, how it is invoked and whether it's possible to use ...
James Blackburn's user avatar
19 votes
2 answers
17k views

Rosetta 2 installation on M1 MBP fails

I'm trying to install rosetta 2 via command line, using this command: /usr/sbin/softwareupdate --install-rosetta Source: https://derflounder.wordpress.com/2020/11/17/installing-rosetta-2-on-apple-...
tmuecksch's user avatar
  • 353
5 votes
1 answer
1k views

Can an application that requires JRE 6 run in Rosetta 2?

I have an application I'd like to run on a new MacBook Air that has as one of its requirements installing Apple JRE 6. Prior to Apple Silicon, this would've been as simple as installing it from Apple'...
Joe's user avatar
  • 358