2

As the title says, could someone accomplish this?

I couldn't. FileVault 2 wizard tells me that the disk isn't compatible with it.

I have only 3 partitions on main disk, and Recovery HD was cloned from original Macbook HD.

macbook-pro:~ $ diskutil list
/dev/disk0
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *256.1 GB   disk0
   1:                        EFI                         209.7 MB   disk0s1
   2:                  Apple_HFS MacOS                   200.0 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3

...

macbook-pro:~$ sudo gpt -r show -l disk0
      start       size  index  contents
          0          1         PMBR
          1          1         Pri GPT header
          2         32         Pri GPT table
         34          6         
         40     409600      1  GPT part - "EFI System Partition"
     409640  390625000      2  GPT part - "Customer"
  391034640  107536528         
  498571168    1269528      3  GPT part - "Recovery HD"
  499840696     277463         
  500118159         32         Sec GPT table
  500118191          1         Sec GPT header

There are 2 places with unpartitionated space. One after my Macintosh "HD" and one that resulted from resizing a 700MB partition to on 650MB for the Recovery partition.

On Console.app the following shows up:

4/14/13 10:07:51.730 AM System Preferences[1868]: *** 
  CoreStorage conversion failed with mainError: -69700; detailError: 0

... when the corresponding message shows up: FileVault can't be turned on for the disk FileVault error alert

PS: sorry I can't direct post the screenshot because I need more points in my reputation, you have to click the link to see it.

1
  • Let's see if anyone has a ready answer. If not, we can help you edit your question to provide more details on what you've tried, what exactly you don't get. See the guides on tour and How to Ask if you don't get an answer and decide to edit your question. They are often helpful in refining / reframing your query.
    – nohillside
    Commented Apr 13, 2013 at 7:50

1 Answer 1

2

OK, I got it working. I partitioned the disk completely from terminal.

disk0 is my internal drive, this is the one going be partitioned. 3 partitions specified, one for OS X, one for Recovery HD, and one with the remaining space for unallocated space/free space/over provisioning. The size parameter (20G) for the last partition isn't really used because diskutil does assign to it the remaining space left unused by the previous two partitions, ie. 256G-200.1G-650M=free space.

Here is how I did it:

macbook-pro:~ $ sudo diskutil partitionDisk disk0 3 GPTFormat jhfs+ MacOS 200.1G jhfs+ Recovery 650M "Free Space" free 20G
Started partitioning on disk0
Unmounting disk
Creating the partition map
Waiting for the disks to reappear
Formatting disk0s2 as Mac OS Extended (Journaled) with name MacOS
Initialized /dev/rdisk0s2 as a 186 GB HFS Plus volume with a 16384k journal
Mounting disk
Formatting disk0s3 as Mac OS Extended (Journaled) with name Recovery
Initialized /dev/rdisk0s3 as a 620 MB HFS Plus volume with a 8192k journal
Mounting disk
Finished partitioning on disk0
/dev/disk0
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *256.1 GB   disk0
   1:                        EFI                         209.7 MB   disk0s1
   2:                  Apple_HFS MacOS                   200.0 GB   disk0s2
   3:                  Apple_HFS Recovery                650.0 MB   disk0s3

...still 2 free space sections ->

macbook-pro:~ $ sudo gpt -r show -l disk0
      start       size  index  contents
          0          1         PMBR
          1          1         Pri GPT header
          2         32         Pri GPT table
         34          6         
         40     409600      1  GPT part - "EFI System Partition"
     409640  390558168      2  GPT part - "MacOS"
  390967808     262144         
  391229952    1269536      3  GPT part - "Recovery"
  392499488  107618671         
  500118159         32         Sec GPT table
  500118191          1         Sec GPT header

... cloned the original recovery partition to the partition for that purpose on the new disk ->

macbook-pro:~ $ sudo asr -source /dev/disk1s3 -target /dev/disk0s3 --erase
Validating target...done
Validating source...done
Erase contents of /dev/disk0s3 (/Volumes/Recovery)? [ny]: y
Validating sizes...done
Restoring  ....10....20....30....40....50....60....70....80....90....100
Verifying  ....10....20....30....40....50....60....70....80....90....100
Remounting target volume...done

...change the partition type ->

macbook-pro:~ $ diskutil unmount disk0s3

macbook-pro:~ $ sudo asr adjust --target /dev/disk0s3 --settype "Apple_Boot"
Fsck /dev/disk0s3 ....10....20....30....40....50....60....70....80....90....100
Adjust completed successfully

...after that I cloned the booteable Macintosh HD partition to a new one on the new disk and then rebooted, went to System Preferences to enable FileVault. It worked! The disk layout after rebooting looks like this ->

macbook-pro:~ $ diskutil list
/dev/disk0
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *256.1 GB   disk0
   1:                        EFI                         209.7 MB   disk0s1
   2:          Apple_CoreStorage                         200.0 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3
/dev/disk1
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                  Apple_HFS MacOS                  *199.6 GB   disk1
/dev/disk2
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *750.2 GB   disk2
   1:                        EFI                         209.7 MB   disk2s1
   2:                  Apple_HFS Macintosh HD            749.3 GB   disk2s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk2s3

Note: disk2 is an external USB 3.0 drive.

1
  • For me all I needed was to unmount and use sudo asr adjust --target /dev/disk0s3 --settype "Apple_Boot". This is after using dd to copy the partition back into place (saved with dd too). Size of the partition does not matter.
    – Tatsh
    Commented Nov 19, 2014 at 0:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .