1

I have a 2019 iMac which is currently running Catalina (10.15.7). This OS was restored from a time machine backup a few months ago after my direct OS upgrade (to Sonoma) failed.

I need to upgrade my OS, this time I am trying an incremental update. My first attempt was to use the app store links here - I tried both Big Sur and Monterey. The Software Update UI window opens, but gets stuck on "Finding Update".

Next I tried from command line: $ sofwareupdate -l --product-types macOS. This also gets stuck on "Finding available software". I looked for errors related to softwareupdate in the console, but did not see anything looking like an error.

Strangely, when I look at the history, softwareupdate does seem to have downloaded Monterey and Sonoma in the past, but not recently (since my time machine restore):

$ softwareupdate --history | grep macOS
macOS Sonoma                                       14.3.1     02/24/2024, 21:49:10  
macOS Monterey                                     12.6.3     01/23/2023, 13:33:32  
macOS Monterey                                     12.6.1     12/05/2022, 18:24:52  
macOS Monterey                                     12.6       10/21/2022, 13:15:06  
macOS Catalina Security Update 2022-005            10.15.7    07/30/2022, 02:12:31

Is there a way to see what is wrong with my current software update process? Or a different way to install a newer OS version?

3
  • Is softwareupdated running? If so, kill it in Activity Monitor and try again.
    – Linc D.
    Commented Jul 1 at 0:06
  • 1
    This does happen from time to time, which I suspect (and it's only a suspicion) that software update has difficulties connecting to Apple's servers if you're on an enterprise network (i.e. university/corporate wifi)? So, it might be worth trying different networks and see if that helps? Furthermore, something you might wish to try is to boot up in safe mode and try software update again. Failing that, try rebooting again normally and see if software update can connect to Apple's servers there. Usually doing a reboot in safe mode, reboot in normal mode and/or changing the wifi fixes the issue.
    – AVelj
    Commented Jul 1 at 3:29
  • Also, some other posts suggests that you can try force quitting in activity monitor the process called com.apple.MobileSoftwareUpdate.UpdateBrainService and then rerun software update. It might have a slightly different name on different macOS versions, so just search "Brain" in Activity Monitor and force quit that process and then rerun software update?
    – AVelj
    Commented Jul 1 at 3:35

1 Answer 1

1

I tried a normal restart, and software update was able to start downloading an OS update quickly this time. I had tried restarting already before posting this question, but apparently the second restart is what the updater needed to be happy.

(I did try killing softwareupdated before the restart but I'm not sure that had any effect. It was running again when I tried the update after restarting)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .