12

When I perform a copy/paste action on my laptop, then go to my Mac mini and whatever I copied on my laptop is now on my Mac mini's paste buffer.

I Googled this and saw something about "universal clipboard," but the directions to turn it off made no sense (it said something about going into System Settings → Display and the option for it isn't even there).

How do I disable this feature? I find it very annoying.

5
  • 7
    I personally find it sooooo useful especially between iPhone and Mac...
    – jcaron
    Commented May 20 at 8:31
  • 2
    I have a KVM switch to switch between two macs. I discovered the handoff-feature when I was looking for my mouse on the "active" mac's screen and discovered it was on the other mac's screen. You can use keyboard & mouse connected to one mac on the other mac two. That freaked me out too, but it works pretty well (I wish they had explained it instead of expecting user to stumble upon their features) Commented May 20 at 10:08
  • Exactly what is most disturbing? That the clipboard is in two places and may overwrite things, or that your data is going via icloud, or via bluetooth ?
    – Criggie
    Commented May 20 at 21:07
  • 3
    @Criggie yes, that it overwrites things. The disturbing part is that I didn't ask for it, and therefore gave me unexpected behavior that was not even clear how to disable.. this should be an opt-in feature, not a default.
    – patrick
    Commented May 20 at 23:05
  • 2
    @ThibaultD. They expect you to watch the Apple keynotes every year (both features were marketed there)
    – user71659
    Commented May 21 at 6:34

1 Answer 1

19

Yes, it's called Universal Clipboard.

You can disable this feature by going to System Settings → General → Air Drop & Handoff and toggling Handoff to the "off" position.

enter image description here

5
  • 9
    I find this confusing because I have iCloud turned off on all my devices... Are they still considered "iCloud devices" even when iCloud is completely disabled??
    – patrick
    Commented May 20 at 3:12
  • 3
    Why are you bringing iCloud into this? You have to be signed in with the same Apple ID, but this feature doesn't use iCloud.
    – Allan
    Commented May 20 at 3:15
  • 27
    @Allan, likely because the very setting you've highlighted says (emphasis mine) "Allow Handoff between this Mac and your iCloud devices". That's a pretty heavy implication in the name of the setting that it's a feature that uses iCloud.
    – Rob
    Commented May 20 at 8:26
  • 8
    In this case it uses BLE or Bluetooth Low Energy. It creates a network interface specifically to talk to iOS devices (awdl0). While you are working with iCloud devices, you're not modifying any iCloud settings. It just so happens that iCloud is where the devices are enumerated.
    – Allan
    Commented May 20 at 14:11
  • 2
    @Allan And certainly, your data is entirely private and not being used (not even in a totally, totally anonymized way, not even, say, for marketing or national security or child porn reasons) by Apple. Never. We swear. Scout's honor. By the way, has anybody seen my canary? Commented May 21 at 18:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .