14

I've been using a Dell U2713H display for about a year with a mini-display port to display port cable.

However, after installing the 10.9.2 update, the monitor is going into sleep mode when connected to the MacBook Pro (as it doesn't think it's getting a signal), even though the laptop thinks it's correctly connected. (If I turn the monitor off, the menu bar, etc. revert to the MBP screen.)

About the only related Mavericks default I've changed is to disable the "Displays have seperate Spaces" option within Mission Control, although I've tried re-enabling this and logging off/on again to no avail.

I've also tried:

  • Forcing the system to use the dedicated GPU rather than the on-board chipset.
  • Resetting the NVRAM and the SMC, neither of which appear to have made any difference.
  • Re-installing the 10.9.2 update
  • Creating a new user account to see if there was a user specific problem
  • Booting in safe mode to ensure no 3rd party apps were affecting things
  • Forcing a re-detect
  • Deleting the /Library/Preferences/com.apple.windowserver.plist file (getting desperate here)
  • Clamshell mode
  • Using the EDID override approach (As per: http://embdev.net/topic/284710)

After looking into this more deeply, System Information states that the monitor is a TV and I wonder if that could be related to the problem.

screen grab from System Information app

My Mac is a 15" MacBook Pro Mid 2010 model.

  • 1
    @middaparka What happens if you — with the display connected — close the lid of the MacBook so there's effectively only one screen? – Lasse Feb 27 '14 at 17:33
  • @Lasse Thanks for the suggestion, but I've tried that (forgot to put it in my list of attempts). Sadly no difference when running in clamshell mode. :-( – John Parker Feb 27 '14 at 17:39
  • TV ? a cable or satellite :), on the non funny site, why is your monitor running in TV mode (the 59 Hz is TV mode)? check your monitor settings, switch ect... – Ruskes Feb 27 '14 at 19:12
  • @Buscar웃 I just double checked - the refresh drop-down is greyed out in the display control panel. – John Parker Feb 27 '14 at 19:50
5

I've just managed to workaround the problem by disabling DisplayPort 1.2 within the Dell OSD.

To do this, you might need to use a bit of a workaround, which is to get the monitor to bring up the input select and then hold down the green tick for ~8 seconds when the (mini-)DisplayPort option is selected. This will bring up a new menu that enables you to enable/disable DisplayPort 1.2 mode. (Green tick to enable/red to disable, etc.)

Whilst I suspect this is just a temporary fix, it at least means that I can use the monitor until Apple fix their seemingly problematic 10.9.2 release.

UPDATE

As an minor update, my bug report has been closed as a duplicate and due to the nature of Apple's "closed" bug tracking system I've no means of viewing the other ticket. However, at least this is a known issue that will presumably be addressed in a successive release.

  • Great find on the DP mode incompatibility. You might even get some engineering support if you filed this as a bug at developer.apple.com/bug-reporting – bmike Feb 28 '14 at 18:18
  • @bmike As a developer I'd already filed a bug report which I updated with my findings - if anything relevant comes from that I'll update my answer. – John Parker Feb 28 '14 at 21:32
  • Perfect. That would be great. – bmike Feb 28 '14 at 22:49
  • Any further advice on how to bring up this OSD? I can't seem to make the monitor bring it up. – Horatio Alderaan Apr 17 '14 at 9:37
  • 1
    This worked for me too (with a Samsung U28D590). I set the monitor to use DP 1.1 and it started to work. OS X 10.10.5). It could also be the DP cable I have is only DP 1.1, no way to be sure other than getting a new cable. – Grynn Sep 9 '15 at 10:04
1

The only workaround I have found for this issue is to revert to the 10.9.1 NVIDIA drivers.

This involves replacing

/System/Library/Extensions/GeForce*
/System/Library/Extensions/NVDA*

with their 10.9.1 equivalents.

  • I've seen some people have to do the same with the AMD drivers on their systems, so I'm guessing this is another option until a fix is released. – John Parker Mar 6 '14 at 22:15
  • Good suggestion, but copying /System/Library/Extensions/AMD* from a friend's 10.9.1 did not restore my Crossover monitor, which uses a Monoprice DisplayPort to dual DVI adapter. Hopefully Apple will fix this soon. – Dan Kohn Mar 7 '14 at 15:46
1

The fix for me was to revert to the 10.9.1 AMD drivers on my iMac to get my Crossover 27" external monitor working again with my Monoprice DisplayPort to dual DVI adapter. The drivers are all available here and I used Kext Wizard to install them.

1

I do not know why your Mac is identifying the Dell display as a television.

You tried some of this but not all so please try it:

1) Reset the System

You can reset the Mac's parameter RAM and SMC.

2) Reset the resolution

Start by resetting the Mac's parameter RAM. If the display does not come up, was previously set to an unsupported resolution, and still results in no video:

  • Start up in Safe Mode.
  • From the Apple () menu, choose System Preferences.
  • Choose Displays from the View menu to open the preferences pane.
  • Select any resolution and refresh rate that your display supports.
  • Restart your computer.

EDIT: Well we were right about the TV mode. here is a very, very long discussion and some possible fixes but I can not try them since i (luckily) do not have that monitor.

  • This may surprise you, but it made no difference. I really think it's a 10.9.2 issue, as there are a few similar problems on the Apple support forum. (Sadly Apple themselves don't bother to actively use their support forum, so that's helpful.) For reference, here's the thread I started there yesterday: discussions.apple.com/thread/5939866?tstart=0 – John Parker Feb 27 '14 at 20:08
  • 1
    see my update, and see if there is anything that helps you, I took me quite some time to find it and read, but it looks like there might be a solution for you. Yes, it is 10.9 doing it by having a wrong profile and reading it as TV :( – Ruskes Feb 28 '14 at 10:11
  • I'd already tried that one (it was the "Using the EDID override approach" item in my list), but thanks for the hunting. I suspect I'll stick with my workaround (as per my own answer) for now, as it means I can get back to working. – John Parker Feb 28 '14 at 11:58
0

Try unplugging your external monitor from your power source, restart your Mac and when you get back to your desktop and your Mac starts blinking plug in your monitor back in. It's a pain in the * doing it every time but it works for me.

-Mavericks 10.9.2 -HP w2228h external monitor -Mini Displayport to HDMI cable

You must log in to answer this question.

protected by Community Apr 4 '15 at 21:59

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .