0

I've got a MacBook Air M1 (a2337) with a drained battery and when trying to recharge it and power it up, nothing worked. I took it to an authorized Apple repair shop, and they could charge it just fine. I thought it was just the cable. I bought a new original Apple cable and it worked for me as well.

Once it had a charge and was powered on, I noticed that both cables I had before could charge it just fine.

Then the next time I drained the battery to zero, it happened again, and this time the new original Apple cable also did not work. I took it back to the same shop and they could also not charge it. They then handed it over to their technicians and then they informed me that the logic board needed to be replaced and it would take 3 to 4 weeks. That wasn't an option for me so refused the service. I tried charging it a few more times, and miraculously after a while it worked.

What stumped me was that once it powered up, it did so as if it had just woken up from sleep mode. It remembered the state of all my dozens of apps including all the tabs in Chrome and displayed them instantly from cache, not like what usually happens when you restart the computer or drain the battery to zero. Then I looked at the battery indicator and it said 1%.

Obviously, something is wrong and I am going to take it to another repair shop, but I was just wondering if anyone could shed some light on what might be causing this.

4
  • Are you regularly draining the battery to zero? I suspect that has done it no favours. And Chrome is well known for using excessive CPU/energy (as well as all the privacy problems). TBH, I would take it to the Apple Store for a repair. Make sure your 'other' repair shop is Apple-certified.
    – benwiggy
    Jan 25 at 18:43
  • Not regularly, but sometimes. Either way, that's unrelated to my issue. Also, my battery maximum capacity is at 90%. And I did take it to an authorized Apple repair shop. The country where I am in has no Apple stores. Jan 25 at 19:17
  • Might not be applicable, but I once had a MBA from 2009, which also displayed at one point 1% battery. After replacing the battery, it was working properly again. However, I did not have the "charging" issue. I think in my case the MacBook was "thinking" there was no battery at all, which throttled the performance, but it still worked when attached to the wall.
    – X_841
    Jan 25 at 20:57
  • 2
    @dan-klasson I would recommend trying to keep the battery within the 20 - 80% range, and avoid draining to 0. There's clearly something wrong with the power management unit, but I'd still recommend being a bit more careful with the battery.
    – benwiggy
    Jan 25 at 21:00

1 Answer 1

2

Likely, the replacement charge/sync cable was a coincidence rather than a cause/effect of your Mac not charging/powering. You may have a failing component with one or more of the power rails and/or Thunderbolt/USB controller chips that take the power input and distributes it. Without putting hands on, it's impossible to know what exactly is the cause of the failure.

It's unfortunate that your particular model MacBook Air didn't include the MagSafe plug as you'd be able to bypass the TB/USB controller for charging and power. However, as you've been advised to replace the logic board, I would look at getting a new(er) MBA. This will give you options like USB or MagSafe charging as well as M1 or M2 processing power.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .