I'm having issue updating macOS from 13.0.1 to 13.1, see the screen recording below:

enter image description here

When I clicked on update -> agree, nothing happened, no update was requested, it was like I was stuck in a loop.

I tried restarting the computer, but it didn't help.

What could I possibly try to fix this issue?

Additional info:

  • I have Xcode command line tools installed and it's up-to-date, version: Command Line Tools for Xcode-14.2.
  • I don't have Xcode app installed.

Update: I tried to use softwareupdate but it stuck too:

❯ softwareupdate -l
Software Update Tool

Finding available software
Software Update found the following new or updated software:
* Label: SafariTechPreview-160
    Title: Safari Technology Preview, Version: 160, Size: 124475KiB, Recommended: YES, 
* Label: macOS Ventura 13.1-22C65
    Title: macOS Ventura 13.1, Version: 13.1, Size: 1147851K, Recommended: YES, Action: restart, 
❯ sudo softwareupdate -i "macOS Ventura 13.1-22C65"
Software Update Tool

Finding available software
Downloading macOS Ventura 13.1

Downloaded: macOS Ventura 13.1
  • 1
    Try running softwareupdate in the Terminal.
    – lhf
    Commented Dec 22, 2022 at 12:40
  • @lhf tried that and got stuck too, please see updated question.
    – Teddy C
    Commented Dec 23, 2022 at 6:58

4 Answers 4


If you are experiencing issues when it lists multiple updates, try installing just one update at a time.

You can click "More Info..." and refine the list to just the OS update, then try.


I had this problem too.

The issue I had was with Xcode command line tools needing an update.

I had to go to AppStore and complete that update first.

  • I guess you probably could have clicked "more info" and installed at least the macOS update by itself first?
    – Redarm
    Commented Dec 22, 2022 at 17:37
  • @Radarm - No I could not. I tried several times. I had to do the Xcode update first
    – mmmmmm
    Commented Dec 22, 2022 at 18:28
  • More info just keeps the loop as shown in the question's gif
    – mmmmmm
    Commented Dec 22, 2022 at 18:29
  • I don't have Xcode app installed, what should I do? Please see updated question.
    – Teddy C
    Commented Dec 23, 2022 at 6:58
  • I had this issue but forget exactly how to fix. But I definitely needed to install Xcode command line before anything else - try selecting that in more info on its own
    – mmmmmm
    Commented Dec 23, 2022 at 8:21

below code helped me fixed this issue:

    softwareupdate -l
    softwareupdate -i "macOS Ventura 13.1-22C65"
  • You might have to try softwareupdate -l several times before it realizes there's an update actually available, per this answer.
    – ijoseph
    Commented May 31, 2023 at 22:53

I had a similar problem. An update was not found at first, and after a few tries of running softwareupdate -l in Terminal, it was found.

When downloading, it was stuck at 15% and so forth so I had to start over with the same loop. I had to download the macOS Ventura installer again (12 GB) and install it. On my Mac Studio with 10 cores, it took just 15 minutes or so.

  • Same, weirdly enough the first softwareupdate -l, like the UI, found no available updates. But! The second time I ran it, it did. So weird and buggy.
    – ijoseph
    Commented May 31, 2023 at 22:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .