I have a simple command to open a new instance of the downloads folder in the Finder, but it does not work under macOS Ventura:

open -n ~/Downloads

which returns

The application cannot be opened for an unexpected reason, error=Error Domain=RBSRequestErrorDomain Code=5 "Launch failed." UserInfo={NSLocalizedFailureReason=Launch failed., NSUnderlyingError=0x6000032c54d0 {Error Domain=NSPOSIXErrorDomain Code=153 "Unknown error: 153" UserInfo={NSLocalizedDescription=Launchd job spawn failed}}}
user@MacBook-Air-Name ~ % 

I have not changed the folder structure at all. So, I'm unsure what the cause is.

  • 1
    Does it only happen with the Downloads folder or also with others? Does it work if you do mkdir ~/ad-test; open -n ~/ad-test?
    – nohillside
    Commented Oct 27, 2022 at 5:26
  • 1
    Interesting. I get this also, but only with the -n option (to open a new instance of Finder, which is already running ofc... ). Also occurs with a newly created folder as per @nohillside M1 MBP, Ventura (13.0). Suggest to OP this is as straightforward as opening a bug with Apple. I also tried with other app, eg opening Numbers sheets. works fine with them, so problem may be restricted to Finder. Commented Oct 27, 2022 at 8:13
  • I'm not 100% certain what fixed it, but I had the same problem with some scripts I was running through npm inside phpstorm. (calling the same command directly in terminal worked though.) But I ran xcode-select --install, and restarted my applications, and now it seems to work? If someone can reproduce, please place this as an answer. Commented Oct 27, 2022 at 9:01
  • 1
    @CasperdeGroot Unfortunately that didn't work for me with Finder. Did the --install and rebooted. Same issue as per OP and my experience. Commented Oct 27, 2022 at 10:26
  • @CasperdeGroot even xcode-select command fails even when xcode is installed
    – Adi.P
    Commented Oct 27, 2022 at 12:40

1 Answer 1


open -n opens a new instance of the same application. You would then have to "Finder" at the same time.

On Monterey, it was not generating an error but was not opening a second instance (it seems that the option was ignored).

On Ventura is giving an error (since having two Finders is most likely not supported).

If you omit the -n option, you will get an additional Finder window with the specified folder

  • Just tested... in Ventura this does NOT give an additional window at the specified folder. It will simply put focus on that Finder window when it's already open. I believe this whole post is about opening an additional Finder, even when there is already a Finder window pointing at the same folder.... Commented May 22, 2023 at 19:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .