I'm trying to update a MacBook Pro (M1 Pro) with 13.2. The update is found when I check the "System Settings". I am 100% certain that the Internet connection is fine and I've got a very large amount of free space. Search results on Google suggest checking the Internet connection (which is fairly laughable; the download actually starts and the machine couldn't have figured out there's an update available without the Internet connection being alive and well) and also disk space. Neither of those things are issues for me.

I've updated the machine before (to 13.1) without incident.

What are things that I can do to figure out why the update fails?

edit — to illustrate that the Internet is clearly working, I've been able to update some random applications: Garage Band, Keynote, Numbers, etc. No issues.

edit again — trying from the command line, it gets a lot farther but then fails. The failure info:

Failed to download & prepare update: Error Domain=SUOSUErrorDomain Code=201 "Failed to personalize the software update. Please try again." UserInfo={NSLocalizedRecoverySuggestion=An error occurred while downloading the selected updates. Please check your internet connection and try again., NSLocalizedDescription=Failed to personalize the software update. Please try again., NSUnderlyingError=0x600003824090 {Error Domain=SUMacControllerError Code=7723 "[SUMacControllerErrorPreflightPersonalizeFailed=7723] Failed to perform PreflightPersonalize operation: [MobileSoftwareUpdateErrorDomain(MSU):MSU_ERR_PERSONALIZATION_FAILURE(2)_1_PersonalizationErrorDomain(Personalization):kAMAuthInstallErrorInternal(14)]" UserInfo={NSLocalizedDescription=Failed to personalize the software update. Please try again., SUMacControllerErrorIndicationsMask=0, NSDebugDescription=[SUMacControllerErrorPreflightPersonalizeFailed=7723] Failed to perform PreflightPersonalize operation: [MobileSoftwareUpdateErrorDomain(MSU):MSU_ERR_PERSONALIZATION_FAILURE(2)_1_PersonalizationErrorDomain(Personalization):kAMAuthInstallErrorInternal(14)], NSUnderlyingError=0x600003824120 {Error Domain=MobileSoftwareUpdateErrorDomain Code=2 "Could not personalize boot/firmware bundle." UserInfo={NSUnderlyingError=0x600003824180 {Error Domain=PersonalizationErrorDomain Code=14 "AMAuthInstallBundlePersonalize() failed: Internal error" UserInfo=0x60000361be60 (not displayed)}, NSLocalizedDescription=Could not personalize boot/firmware bundle., target_update=22D49}}}}}

edit yet again — ok after rebooting and rebooting it's now 1.52 gb into the update process, I have no clue what's going on with this thing. Typing this so that if it happens to anybody else you'll know you're not alone. (To be clear I'm back to the "Software Update" UI, which I tried just for kicks.)

  • My update, via the normal UI update mechanism, finally worked. I really did nothing that I can identify that might have "fixed" whatever was wrong; honestly other than reboot a few times I did nothing at all other than retry the operation.
    – Pointy
    Commented Feb 8, 2023 at 1:02
  • It's seriously unclear why anybody should have to do anything to make this work. It's a basic function of the operating system. edit oh lol this is my own question
    – Pointy
    Commented Sep 20, 2023 at 22:00

2 Answers 2


I was getting same error .. “failed to personalise the software’s update” .. with my M1 MacBook Air. I could not update from Monterey to Ventura, or indeed update Monterey to a later Monterey version. I spent hours on this. Eventually I set up another admin user on my system and the update worked perfectly for me, logged in as the new user.


I had this problem, and here's how I fixed it:

At first, I tried deleting the update. Navigated over to /Library/Updates/ and to my surprise, there was no update...

Eventually, I tried downloading straight from the App Store. This of course redirected me back to System Settings and wouldn't you know it, the update proper began downloading.

Apparently, my Mac was under the impression it had downloaded an update which it actually hadn't. Going through the App Store forced it to re-initiate the download.

This was for the 13.4.1 update.

Reinstalling Ventura via the MacOS Recovery allowed me to install 13.4.1. However, now I'm getting the same error with the 13.4.1(c) security update.

Oh well.

It seems that Migration Assistant screwed up my installation of Little Snitch. There’s a bug in macOS Ventura causing "Full Disk Access" to fail to work properly. As a result, "Full Disk Access" for the "Little Snitch Endpoint Security" cannot be granted, or is lost on every restart.

Follow these instructions if this applies to you.

  1. Open "System Settings", click on "Privacy & Security", and navigate to "Full Disk Access".
  2. Right-click the "Little Snitch Endpoint Security" item and choose "Show in Finder".
  3. With the newly opened Finder window kept open, switch back to "System Settings".
  4. Left-click the "Little Snitch Endpoint Security" in the list to select it.
  5. Remove it by clicking the (-) minus button at the bottom of the list.
  6. Switch back to the Finder window showing an item named "Little Snitch Endpoint Security" (other possible other items).
  7. Select the "Little Snitch Endpoint Security" item and drag and drop it onto the "Full Disk Access" list in "System Settings".
  • I have Little Snitch but it's not causing me a problem on my personal MacBook Pro, however thank you for the response.
    – Pointy
    Commented Sep 21, 2023 at 0:11
  • @Pointy they’ve patched the issue since I posted this as far as I can tell. Commented Sep 22, 2023 at 1:05
  • 1
    Well on the laptop that I do have Little Snitch installed, my 13.5.2 update went fine without incident. On another MacBook Pro (M1 Pro), getting 13.5.2 to install took many many repeated tries over the course of two days and many reboots into "safe" mode. The whole thing is insane, there appears to be absolutely no technical information about the problem anywhere on the internet. However, I do thank you for your help.
    – Pointy
    Commented Sep 22, 2023 at 1:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .