1

How to type special characters in iTerm2 using dead keys, e.g. typing

Opt ⌥ + e + e should give é

also in iTerm.

Note, there is a workaround as in this answer https://apple.stackexchange.com/a/440335/286394, which essentially changes the Input Source to US International PC. This allows to type

' + e which gives é

Other Mac apps work properly, just not iTerm. Is there a setting or change I might make to get this working?

2
  • Have you tested to see if Apple’s native terminal.app or notes.app works? Knowing if this is system general or iTerm specific might help narrow the fix.
    – bmike
    Sep 26, 2022 at 10:48
  • @bmike, yes I tested it with the terminal.app, there it works.
    – Stefan
    Sep 26, 2022 at 14:52

1 Answer 1

1

By default iTerm2 is configured to send Esc+ by Altgr. So just switch it to Normal as on my screenshot.

Settings

1
  • This indeed works. The corresponding config settings are: "Right Option Key Sends" : 2, "Option Key Sends" : 2, with 0 for Normal and 2 for Esc+.
    – Stefan
    Jun 21, 2023 at 10:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .