I have a 2017 MacBook Pro 15 with a fairly new battery. One day it just suddenly switched off with 80% battery remaining and when I switched it on (or tried to) it said the battery was empty.

Since then the MacBook switches off randomly while reporting a full state of charge and when I do plug it in to charge it, it charges from 0% to 5% - 15% then it jumps to 100% all in about less than 15 minutes.

I found this command ioreg -l -w0 | grep Capacity and it showed me something interesting. Apparently, the battery is made up of three cells each at about 4.35V when fully charged... the peculiar thing is that the reported voltages of one cell differs from the rest. eg... (4216mV, 3521mV, 4210mV). The MacBook usually switches off when the faulty cell has less than 2800mV. (When on low power mode and screen brightness at minimum)

So I figured the reason my MacBook swithes off while it reports > 80% battery is because one of the cells is way more depleted than the rest, then when the battery voltage drops below the minimum (I think around 11.2V) to run to electronics then it switches of

Here's a sample output of ioreg -l -w0 | grep Capacity:

└─[$] ioreg -l -w0 | grep Capacity                                                                                                                                                                                                                                 [17:18:58]
| |           "AppleRawCurrentCapacity" = 6971
| |           "AppleRawMaxCapacity" = 7128
| |           "MaxCapacity" = 7128
| |           "CurrentCapacity" = 6971
| |           "LegacyBatteryInfo" = {"Amperage"=18446744073709550486,"Flags"=4,"Capacity"=7128,"Current"=6971,"Voltage"=11713,"Cycle Count"=12}
| |           "BatteryData" = {"LifetimeData"={"TotalOperatingTime"=28160,"UpdateTime"=1655739345,"AverageTemperature"=273,"Raw"=<0000000000483ff4000108f100000000060ae9c40080e467b24000000000000001d9004e1106084b33091fc6155be5271a8ce074eadce8ac01110006e0070031>,"TimeAtHighSoc"=<00000000230500001200000000000000>},"Serial"="C01514309YEF90MA4","ChemID"=3165,"Flags"=192,"DataFlashWriteCount"=0,"PassedCharge"=18446744073709550538,"Voltage"=11798,"ResScale"=167,"RaTableRaw"=(<0000000000000000000000000000000000000000000000000000000000000000>,<0000000000000000000000000000000000000000000000000000000000000000>,<0000000000000000000000000000000000000000000000000000000000000000>),"StateOfCharge"=98,"Qmax"=(6580,6600,6590),"CycleCount"=12,"DesignCapacity"=6600,"SystemPower"=1497,"AdapterPower"=0,"PMUConfigured"=192,"DOD0"=(9280,9344,9248),"PresentDOD"=(40,41,40),"CellVoltage"=(4214,3276,4223)}

As you can see the battery is quite new (cycle count = 12) and the faulty cell, "CellVoltage"=(4214,3276,4223)

Can any please help me fix this issue? The battery lasted about 6 hours with moderately heavy use which was perfect for me to outside to the park or a coffee shop and code there instead of being stuck in the four walls named my bedroom.

I think I need to find a way too either charge only the depleted cell or to discharge the full cells. I'm hoping to get a software solution as first preference, or I can right my own code to manage the charging if software like that doesn't exist and my last option is to open up the MacBook and manually discharge the other two cells which I don't think is a good idea... Or maybe I have made the wrong diagnosis and there's a different solution to my problem.

I have tried reseting the SMB and NVRAM with no luck.

  • 3
    Was this battery replaced by an Apple-authorised repair shop? If so, it should be under warranty.
    – benwiggy
    Commented Jun 20, 2022 at 16:29
  • 1
    … if not, send it back anyway.
    – Tetsujin
    Commented Jun 20, 2022 at 16:50
  • Sending it back is not an option... Commented Jun 20, 2022 at 19:03
  • 1
    Then your option is to replace it again or live with it. Wherever you got it from sold you a battery with a bad cell. Commented Jun 20, 2022 at 19:09
  • Well this only happened after I installed an app called charge limiter to limit the battery to 80% charge. So I 'm not entirely convinced it just the case of a bad cell. That app was on GitHub so I think on the weekend I'll go over the source code, maybe I can find a way to make it charge the faulty cell or discharge the other two. Commented Jun 22, 2022 at 13:04

2 Answers 2


You describe the classic signs of a battery that has gone outside the “healthy” regime for safe charging and will need to replace the battery.

I have not seen anyone that can use software to fix this. The technical skills needed to remanufacture the battery and replace one of three cells is also beyond DIY repairs and a fire hazard. The system is telling you it’s not going to charge this battery and also that the battery isn’t providing the required voltage to have a healthy system.

Hopefully return windows and education help everyone when shopping for replacement batteries and you can source a better part next time.


After doing some reading, I think the mostly cause is that it was shipped to me with a low state of charge and it took 11 days to arrive. When it it arrived I had to leave it plugged in for about 5 minutes before it switched on.

The battery seems to be genuine (Manufacturer is SMP).

So looks like I just have to get it replaced. A friend bought it for me in USA and had it shipped to South Africa.

Now I know that it is very important to make sure devices with batteries should be at 50% charge if left unused for more than a couple of days.

  • Apple doesn't sell replacement batteries to the public (though is making plans to do so), so anything you bought will be 'grey' -- either extra units made in the factory that makes them for Apple, which are then sold on without Apple's permission; or just counterfeit models based on similar spec, from the factory next door.
    – benwiggy
    Commented Dec 18, 2022 at 9:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .