1

Using macOS Monterey 12.4 and have this shortcut set for Mission Control:

Screenshot of Keyboard Preferences showing the Shortcuts tab

I have changed the Move left/right a space and activated these shortcuts.

I also have Karabiner Elements, but it doesn't interfere with this setup.

These shortcuts stop working in the vanilla Terminal app as well as iTerm2. I have tried the below so far:

  • Remove all shortcuts from iTerm2 window controls
  • Remove all shortcuts from iTerm2 profile

Restarted my Mac.

It appears that somehow, both iTerm2 and Terminal cancel any other system shortcuts. Is there a way to force iTerm2 and Terminal to respect these 2 specific shortcuts related to Mission Control?

Any suggestion that works is welcome. Preferably, some Karabiner Elements profile.

1
  • So today I found out that if I use ⌘⌥ + ⬅/➡ I can switch the virtual desktops. Not sure why CTRL key is being held hostage by iTerm and Terminal app, but if anybody has a solution to this I'd be happy to explore it.
    – Mike O.
    Jun 23 at 7:35

1 Answer 1

1

The culprit was actually one single complex rule in Karabiner Elements which enabled ^ + Left/Right jumping like on PC. As soon as I removed it, the Mission Control shortcuts worked system-wide.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .