I am using sshfs a lot to mount external disks using MacOS 12.3.1. The command I am using is something like

sshfs [email protected]:/remote_folder ~/remote -o 'allow_other,gid=10067'

and then this remote location is available in my terminal under remote. Because I created a folder named remote in my home folder.

However, when I use "Finder" to navigate to that remote mounted folder, I see the following instead:

enter image description here

Finder does not show this folder remote as remote, but instead as macFUSE Volume 0 (sshfs). This can become extremely annoying if you have more than one folder mounted. Because then you do not know which one to use, as "Finder" decided to rename them.

How can I fix this problem? How can I make Finder to show the folder remote with the name remote? Not with label apple, not banana, not macFUSE Volume 0 (sshfs), but remote...?


2 Answers 2


There is a volname argument. Have you tried adding


… when you use ssh to make sftp build a snapshot of the remote filesystem locally on your Mac.


I followed this post: https://www.itsfullofstars.de/2022/03/mount-a-remote-directory-via-ssh-on-macos-sshfs/

and the -ovolname=remote option that @bmike mentioned worked for me on Apple M2 Pro, Ventura 13.3.

  • While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. - From Review
    – Thinkr
    Jun 12, 2023 at 8:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .