I'm having issues with automount with my NFS shares after upgrading to MacOS Monterey 12.3.1.


# Automounter master map
/System/Volumes/Data/mnt auto_mounts
+auto_master            # Use directory service
#/net                   -hosts          -nobrowse,hidefromfinder,nosuid
/home                   auto_home       -nobrowse,hidefromfinder
/Network/Servers        -fstab
/-                      -static


$ sudo automount -vc
automount: /System/Volumes/Data/mnt mounted
automount: /System/Volumes/Data/home updated (/home -> /System/Volumes/Data/home)
automount: no unmounts
$ ls -l /System/Volumes/Data/mnt/
total 0
ls: fts_read: Input/output error

Any ideas? I have already tried a bunch of things, including manually mounting the shares with mount -t nfs.

  • Is the share really an NFS share? If not, the format of your auto_mounts is wrong and your entry is going to get treated as an NFS share. See man auto_master sections AUTOMOUNTER MAP on the format for SMB/CIFS shares.
    – DarkDust
    May 2, 2022 at 6:46
  • yes, definitely are NFS shares. I actually have 2 separate NFS shares on different servers. I can manually mount those using the 'mount -t nfs' command. May 2, 2022 at 16:23

2 Answers 2


does the manual mount -t nfs blah.blah:/blah end up also being mounted to /homes/?

when operating with SIP active you shouldn't be allowed to mount a filesystem to a directory at / on your boot volume unless you've also configured /etc/synthetic.conf to create those directories you'll mount filesystems at.

i don't use macOS automount these days but unless /home/mynas is there at boot nothing can be hitched to it. my creative workstation has a local zpool (two pairs of mirrored 4TB NVMe drives in a thunderbolt 3 "jbod" of sorts) and here's an example of how i've configured for (direct-attached mind you but similar constraints) my zpool in /etc/synthetic.conf:

# zpool cascade:

av      cascade/av
devel       cascade/developer
it      cascade/it
phones      cascade/it/deviceManagement
people      cascade/people

it'll create the directories on boot. i also have some convience options like my dropbox folder being available at /dropbox:

dropbox     Volumes/µ/fs/Dropbox

etc. i use /onedrive/ on my employer-provided workstation.

if the directory isn't there automount probably can't mount to it. and if automount can't mount to it, the mount will fail. before i knew how to do this the right way with /etc/synthetic.conf i hacked out some crazy shit in an unlocked unsealed APFS volume and i'm pretty sure it caused other problems later so i was pretty excited to learn about that file!


Looks like the file /etc/auto_nas content is incomplete. try: nas -rw


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .